Playback of live DASH (MSE) stream intermittently not starting

RESOLVED DUPLICATE of bug 1269178

Status

()

P1
normal
RESOLVED DUPLICATE of bug 1269178
2 years ago
2 years ago

People

(Reporter: lloyd.wallis, Unassigned)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8769628 [details]
ffmse.log

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.60 Safari/537.36

Steps to reproduce:

1. Visit bbc.co.uk/html5 on FF stable on a Mac (we've reproduced on latest stable and preview builds) and opt in (or don't have Flash available)
2. Visit bbc.co.uk/iplayer/live/bbcone


Actual results:

The stream intermittently does not play back.

On the page, you can execute document.getElementsByTagName('iframe')[0].contentWindow.publicApi.mediaPlayer.currentTime = document.getElementsByTagName('iframe')[0].contentWindow.publicApi.mediaPlayer.currentTime and playback will immediately start.


Expected results:

The stream should start playback.
preliminary investigation shows that it's likely a duplicate of bug 1269178.

will keep it open for now while I can confirm that it is indeed the case
See Also: → bug 1269178
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core
Priority: -- → P1
See Also: bug 1269178
LLoyd - does bug 1269178 fix the issue?
Flags: needinfo?(lloyd.wallis)
(Reporter)

Comment 3

2 years ago
I've just retested on 49b1, and can no longer reproduce the issue, so I'm going to say that yes, bug 1269178 fixed this issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(lloyd.wallis)
Resolution: --- → DUPLICATE
Duplicate of bug: 1269178
You need to log in before you can comment on or make changes to this bug.