a:hover causes one line of text to be broken into two lines of text

RESOLVED WORKSFORME

Status

()

Core
Layout: Tables
P3
minor
RESOLVED WORKSFORME
16 years ago
11 years ago

People

(Reporter: Dale Feinstein, Unassigned)

Tracking

({testcase})

Trunk
Future
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [reflow-refactor], URL)

Attachments

(1 attachment)

394 bytes, text/html
Details
(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020406

When viewing http://www.srsd.org/~dfeinstein/test.html with Mozilla 0.98 (and
Netscape 6.2.1), the link "Southern Regional School District" appears on one
line.  However, once passing the mouse pointer over this link, this link is
broken into two lines, with "Southern Regional School" on one line and
"District" on the line below.

In this example, a:hover is used in the following manner:

a:hover {color: red; background-color: silver; border-width: 1px; border-color:
black; border-style: dotted; padding: 2px; text-decoration: none;}


When testing http://www.srsd.org/~dfeinstein/test.html in Internet Explorer 5.5
and 6.0, the link remains on one line when passing the mouse pointer over it.


Reproducible: Always
Steps to Reproduce:
1.  Access http://www.srsd.org/~dfeinstein/test.html
2.  Pass mouse pointer over the link, "Southern Regional School District"


Actual Results:  This link which was previously one line is now broken into two
lines, with "Southern Regional School" on one line, and "District" on the line
below.

Expected Results:  The link, "Southern Regional School District", should have
remained on one line, instead of being broken up into two lines.

Comment 1

16 years ago
Confirming on 2002022603 Win2k. Looks more like a problem with the Style System
than with Event Handling to me, though.
Status: UNCONFIRMED → NEW
Ever confirmed: true
And after you move the mouse back off, the line stays wrapped.

-> layout for first look, but could be tables, or style.
Assignee: joki → attinasi
Component: Event Handling → Layout
QA Contact: madhur → petersen

Comment 3

16 years ago
Changing QA contact
QA Contact: petersen → amar

Updated

16 years ago
Priority: -- → P3
Target Milestone: --- → Future

Comment 4

16 years ago
*** Bug 163864 has been marked as a duplicate of this bug. ***

Comment 5

16 years ago
This is the testcase from the duplicate bug 163864:
http://bugzilla.mozilla.org/attachment.cgi?id=96186&action=view

(click on the links in the testcase to see bug).
Assignee: attinasi → karnaze
Severity: normal → minor
Component: Layout → HTMLTables
OS: Windows 98 → All
Hardware: PC → All
Target Milestone: Future → ---

Updated

16 years ago
Target Milestone: --- → Future

Comment 6

15 years ago
mass reassign to default owner
Assignee: karnaze → table
QA Contact: amar → madhur
Target Milestone: Future → ---

Updated

15 years ago
Target Milestone: --- → Future

*** This bug has been marked as a duplicate of 215857 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
er.. that's not what I meant to do.  :(
Status: RESOLVED → REOPENED
Depends on: 215857
Resolution: DUPLICATE → ---
Whiteboard: [reflow-refactor]
No longer depends on: 215857

Comment 9

14 years ago
Created attachment 162306 [details]
testcase

Updated

14 years ago
Keywords: testcase

Comment 10

12 years ago
This WFM using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060527 Minefield/3.0a1 ID:2006052705
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20061208
Minefield/3.0a1 ID:2006120812 [cairo]

fixed when reflow branch landed on trunk

Comment 12

11 years ago
this worked before --> WFM
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.