Closed Bug 1286057 Opened 6 years ago Closed 6 years ago

Background page is not _generated_background_page.html

Categories

(WebExtensions :: Untriaged, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1234677

People

(Reporter: robwu, Assigned: robwu)

Details

Currently the background page is moz-extension://[guid]/blank.html, and the scripts are inserted by the background page initialization logic.

The issue with that is that it breaks the following use cases:

- Using location.reload() to reload the background page.
- Opening location.href in a new window to debug the background page logic in a tab.
Summary: Background page is not _generated_background.html → Background page is not _generated_background_page.html
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1234677
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.