Intermittent dom/indexedDB/test/test_rename_index.html | Test timed out.

RESOLVED DUPLICATE of bug 1300454

Status

()

Core
DOM: IndexedDB
P3
normal
RESOLVED DUPLICATE of bug 1300454
a year ago
a year ago

People

(Reporter: Treeherder Bug Filer, Assigned: bevis)

Tracking

({intermittent-failure})

unspecified
intermittent-failure
Points:
---

Firefox Tracking Flags

(e10s-, firefox50 affected, firefox51 affected, firefox52 affected)

Details

(Reporter)

Description

a year ago
treeherder
Filed by: tomcat

https://treeherder.mozilla.org/logviewer.html#?job_id=4327016&repo=mozilla-central

http://archive.mozilla.org/pub/firefox/tinderbox-builds/mozilla-central-linux-debug/1468313967/mozilla-central_ubuntu32_vm-debug_test-mochitest-e10s-3-bm01-tests1-linux32-build17.txt.gz

Comment 1

a year ago
13 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-central: 4
* fx-team: 4
* mozilla-inbound: 3
* autoland: 2

Platform breakdown:
* linux32: 12
* linux64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1286210&startday=2016-07-11&endday=2016-07-17&tree=all

Comment 2

a year ago
13 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 4
* fx-team: 4
* autoland: 4
* mozilla-central: 1

Platform breakdown:
* linux32: 13

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1286210&startday=2016-07-18&endday=2016-07-24&tree=all

Comment 3

a year ago
50 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 21
* fx-team: 9
* autoland: 8
* mozilla-central: 7
* try: 5

Platform breakdown:
* linux32: 46
* linux64: 3
* windows7-32-vm: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1286210&startday=2016-07-25&endday=2016-07-31&tree=all

Comment 4

a year ago
19 automation job failures were associated with this bug yesterday.

Repository breakdown:
* try: 9
* mozilla-inbound: 4
* autoland: 3
* fx-team: 2
* mozilla-central: 1

Platform breakdown:
* linux32: 17
* linux64: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1286210&startday=2016-08-05&endday=2016-08-05&tree=all

Comment 5

a year ago
95 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* try: 35
* mozilla-inbound: 30
* autoland: 15
* mozilla-central: 6
* fx-team: 6
* mozilla-aurora: 2
* ash: 1

Platform breakdown:
* linux32: 87
* linux64: 8

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1286210&startday=2016-08-01&endday=2016-08-07&tree=all

Comment 6

a year ago
52 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* try: 16
* autoland: 16
* mozilla-inbound: 11
* fx-team: 6
* mozilla-aurora: 2
* mozilla-central: 1

Platform breakdown:
* linux32: 47
* linux64: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1286210&startday=2016-08-08&endday=2016-08-14&tree=all

Comment 7

a year ago
37 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 11
* autoland: 11
* mozilla-aurora: 5
* fx-team: 4
* try: 3
* mozilla-central: 3

Platform breakdown:
* linux32: 30
* linux64: 7

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1286210&startday=2016-08-15&endday=2016-08-21&tree=all

Comment 8

a year ago
25 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 9
* autoland: 7
* fx-team: 4
* try: 2
* mozilla-aurora: 2
* mozilla-central: 1

Platform breakdown:
* linux32: 24
* linux64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1286210&startday=2016-08-22&endday=2016-08-28&tree=all
Bevis, can you please take a look at this frequent failure?
Flags: needinfo?(btseng)
(Assignee)

Comment 10

a year ago
The test in window was not started after test in worker is done.
take this bug to do more investigation.
Assignee: nobody → btseng
Flags: needinfo?(btseng)

Comment 11

a year ago
Bulk assigning P3 to all open intermittent bugs without a priority set in Firefox components per bug 1298978.
Priority: -- → P3
65 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 25
* autoland: 21
* mozilla-aurora: 7
* mozilla-central: 6
* fx-team: 4
* try: 2

Platform breakdown:
* linux32: 55
* linux64: 10

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1286210&startday=2016-08-29&endday=2016-09-04&tree=all
(Assignee)

Updated

a year ago
Blocks: 1300454
57 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 21
* autoland: 20
* fx-team: 7
* mozilla-central: 4
* try: 3
* mozilla-aurora: 2

Platform breakdown:
* linux32: 45
* linux64: 12

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1286210&startday=2016-09-05&endday=2016-09-11&tree=all
(Assignee)

Comment 14

a year ago
Note: all these happens in e10s + linux32/linux64 (more frequent in linux 64) according to the statistics so far.
Summary: Intermittent dom/indexedDB/test/test_rename_index.html | Test timed out. → e10s - Intermittent dom/indexedDB/test/test_rename_index.html | Test timed out.
Whiteboard: e10s
(Assignee)

Comment 15

a year ago
In addition, I am going to do some comparison to see if db.close() at the end of the test would impact the stability of the test
with db.close(), what we have in m-c currently:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=902f244835d7
without db.close():
https://treeherder.mozilla.org/#/jobs?repo=try&revision=2ab0beb6ccaa
(Assignee)

Comment 16

a year ago
(In reply to Bevis Tseng[:bevistseng][:btseng] from comment #14)
> Note: all these happens in e10s + linux32/linux64 (more frequent in linux
> 64) according to the statistics so far.
typo: It's more frequent in linux 32 instead.

Updated

a year ago
tracking-e10s: --- → -
(Assignee)

Comment 17

a year ago
(In reply to Bevis Tseng[:bevistseng][:btseng] from comment #15)
> In addition, I am going to do some comparison to see if db.close() at the
> end of the test would impact the stability of the test
> with db.close(), what we have in m-c currently:
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=902f244835d7
> without db.close():
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=2ab0beb6ccaa

There is no much difference whether db.close() is called at the end of the test.
I'll add more log to figure out why there is no response after requesting QuotaManagerService to clean up the storage of the specified origin.
(Assignee)

Comment 18

a year ago
https://treeherder.mozilla.org/#/jobs?repo=try&revision=9a663e95a046
54 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 21
* autoland: 16
* fx-team: 9
* mozilla-central: 4
* try: 3
* mozilla-aurora: 1

Platform breakdown:
* linux32: 41
* linux64: 13

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1286210&startday=2016-09-12&endday=2016-09-18&tree=all
(Assignee)

Comment 20

a year ago
From the logging in 
https://treeherder.mozilla.org/logviewer.html#?job_id=27701983&repo=try#L27106-L27118
We can see that the test harness was blocked at 
http://searchfox.org/mozilla-central/rev/dbbbafc979a8362a1c8e3e99dbea188fc832b1c5/dom/indexedDB/test/helpers.js#185

The clearAllDatabases() request was blocked because its directory lock in QuotaManager was still waiting for the release of the previous lock used by the test in worker (which has never been released):
01:57:19 INFO - BVS, DirectoryLockImpl::MustWaitFor() returns true!
01:57:19 INFO - BVS, DirectoryLockImpl::MustWaitFor() returns true!

The next step is to figure out why the directory lock was not released.
20 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 7
* autoland: 7
* fx-team: 3
* mozilla-aurora: 2
* try: 1

Platform breakdown:
* linux32: 13
* linux64: 7

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1286210&startday=2016-09-21&endday=2016-09-21&tree=all
65 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 24
* autoland: 15
* fx-team: 8
* try: 6
* mozilla-central: 6
* mozilla-aurora: 6

Platform breakdown:
* linux32: 52
* linux64: 13

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1286210&startday=2016-09-19&endday=2016-09-25&tree=all
15 automation job failures were associated with this bug yesterday.

Repository breakdown:
* autoland: 7
* mozilla-inbound: 6
* try: 1
* fx-team: 1

Platform breakdown:
* linux32: 8
* linux64: 7

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1286210&startday=2016-09-28&endday=2016-09-28&tree=all
(Assignee)

Comment 24

a year ago
More debug info needed to narrow down the issue:
1. Add lockId in DirectoryLock to see which lock was not released.
2. Add more logs in OpenDirectoryListener::DirectoryLockAcquired(),  NormalOriginOperationBase::UnblockOpen(), OpenDatabaseOp::ConnectionClosedCallback(), and Database::ConnectionClosedCallback() to see who is the lock owner and whether the lock is released accordingly when the operation is done.
(Assignee)

Updated

a year ago
Summary: e10s - Intermittent dom/indexedDB/test/test_rename_index.html | Test timed out. → Intermittent dom/indexedDB/test/test_rename_index.html | Test timed out.
Whiteboard: e10s
73 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 29
* autoland: 22
* fx-team: 7
* mozilla-central: 6
* try: 4
* mozilla-aurora: 4
* mozilla-beta: 1

Platform breakdown:
* linux32: 47
* linux64: 26

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1286210&startday=2016-09-26&endday=2016-10-02&tree=all
(Assignee)

Comment 26

a year ago
Note: the fix is available now in bug 1300454 and ins waiting for the review.
19 automation job failures were associated with this bug yesterday.

Repository breakdown:
* autoland: 7
* mozilla-inbound: 5
* fx-team: 5
* mozilla-central: 1
* mozilla-aurora: 1

Platform breakdown:
* linux32: 10
* linux64: 9

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1286210&startday=2016-10-04&endday=2016-10-04&tree=all
No longer blocks: 1300454
status-firefox50: --- → affected
status-firefox51: --- → affected
status-firefox52: --- → affected
Depends on: 1300454
35 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* autoland: 13
* try: 7
* mozilla-inbound: 6
* fx-team: 5
* mozilla-aurora: 2
* mozilla-central: 1
* mozilla-beta: 1

Platform breakdown:
* linux32: 19
* linux64: 16

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1286210&startday=2016-10-03&endday=2016-10-09&tree=all
(Assignee)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1300454
You need to log in before you can comment on or make changes to this bug.