Add a scripted way of generating values in css-properties-db.js

RESOLVED FIXED in Firefox 50

Status

DevTools
Framework
P1
enhancement
RESOLVED FIXED
2 years ago
a month ago

People

(Reporter: gregtatum, Assigned: gregtatum)

Tracking

49 Branch
Firefox 50
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox50 fixed)

Details

(Whiteboard: [devtools-html])

Attachments

(1 attachment, 1 obsolete attachment)

In the work to separate the client and server in devtools, we are creating a static list of CSS properties on the client. The list has been hand-generated every time. At this time we need a script to re-generate all of the values, and instructions on how to update the file. At this time this does not need to be included in the build system as that would be a lot of additional complexity. The script should be able to simply run from the Browser Console.

This bug came out of discussions from Bug 1265785.
(Assignee)

Updated

2 years ago
Whiteboard: [devtools-html]
(Assignee)

Updated

2 years ago
Blocks: 1275939

Updated

2 years ago
Blocks: 1263287
Whiteboard: [devtools-html] → [devtools-html] [triage]
Severity: normal → enhancement

Updated

2 years ago
Assignee: nobody → gtatum
Status: NEW → ASSIGNED
Iteration: --- → 50.3 - Jul 18
Flags: qe-verify?
Priority: -- → P1
Whiteboard: [devtools-html] [triage] → [devtools-html]

Updated

2 years ago
Flags: qe-verify? → qe-verify-
(Assignee)

Comment 2

2 years ago
Created attachment 8771054 [details] [diff] [review]
Add scripts and tests to automate the css-properties-db.

I ended up combining this bug and Bug 1286238 as the testing bug was already failing due to the fact that the CSS properties database has already changed! I'd have to land the scripting bug, then land the testing patch. In the interest of time they are combined here. I'm keeping this pretty manual, but I'm trying to be as explicit as I can in how to update the database so that anyone can come in and update it.
Attachment #8771054 - Flags: review?(pbrosset)
Comment on attachment 8771054 [details] [diff] [review]
Add scripts and tests to automate the css-properties-db.

Review of attachment 8771054 [details] [diff] [review]:
-----------------------------------------------------------------

This looks great! Thanks a lot. Feels like we are in a much better position now to prevent future de-sync with platform and it'll be really easy to re-generate the lists.
Attachment #8771054 - Flags: review?(pbrosset) → review+

Updated

2 years ago
Duplicate of this bug: 1286238

Updated

2 years ago
Iteration: 50.3 - Jul 18 → 50.4 - Aug 1
(Assignee)

Comment 9

2 years ago
Created attachment 8773275 [details] [diff] [review]
Add scripts and tests to automate the css-properties-db.

This patch removes OS-specific tags, and makes the failing test more verbose
and specific to what failed.
(Assignee)

Updated

2 years ago
Attachment #8771054 - Attachment is obsolete: true
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Comment 10

2 years ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/fx-team/rev/7e5277f1cf65
Add scripts and tests to automate the css-properties-db. r=pbro
Keywords: checkin-needed

Comment 11

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/7e5277f1cf65
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox50: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 50
Depends on: 1290971

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.