Status

()

Firefox
Screen Sharing Whitelist
RESOLVED WONTFIX
a year ago
8 months ago

People

(Reporter: Stewart Taylor, Unassigned)

Tracking

Trunk
All
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
>> Vendor name
LoopUp

>> Point of contact
stewart.taylor@loopup.com, paul.wozniak@loopup.com

>> Site URLs
*loopup.com

>> Does the application provide users with notice and control?
Yes, we provide the user with controls to allow them to decide what to display.
All users have to agree to our privacy policy.

http://loopup.com/legal/privacy-policy

>> Have you seen and agree with the Developer Screen Sharing Submission policy?
Yes

>> Does the usage comply with the Developer Screen Sharing Submission Policy guidelines?
Yes

Comment 1

8 months ago
Hi, I am resolving this bug as "won't fix", since starting Firefox 52 on April 18th the Screensharing whitelist is no longer needed to share your screen or windows. Please let us know if you find any problems!

        Much of this work was front-end, UX/UI changes, including support to let the UI know what streams are "scary" to share (see bug 1284910). See the meta bug 1127522 for all the work that went into this.

        Please read Jan-Ivar's blog post explaining the risks that users need to know about when sharing their screen or windows: https://blog.mozilla.org/webrtc/share-browser-windows-entire-screen-sites-trust/.

        The new UI permission dialog for screensharing links to a SUMO article with similar content to Jan-Ivar's post, but our SUMO team tailored it to a less technical user.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.