If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Print Background Colors no longer works

RESOLVED INVALID

Status

()

Core
Print Preview
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: webshaman, Unassigned, NeedInfo)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

474 bytes, text/html
Details
(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160623154057

Steps to reproduce:

Display a local generated webpage that I use CSS/styles to display background colors throughout the page.  Open Options in Print Preview, selecting/deselecting Print Background Colors/Styles Option does NOTHING.  No Background Colors ever display on Print Preview.


Actual results:

No background colors/styles display for printing, and can NOT be printed.


Expected results:

Background colors/styles should print.

Comment 1

a year ago
Can you attach the page (html file), please.
Flags: needinfo?(webshaman)
(Reporter)

Comment 2

a year ago
Any table with background colors and/or styles will do, for example:
--
<table style="FONT-SIZE: 10px; HEIGHT: 391px; BORDER-TOP-COLOR: ; WIDTH: 1044px; BORDER-LEFT-COLOR: ; COLOR: ; BORDER-BOTTOM-COLOR: ; BORDER-RIGHT-COLOR: ; border: 1px solid black; " border="0" cellpadding="0" cellspacing="1">
    <tbody>
        <tr>
<td id="__tmpTD" style="BORDER-RIGHT: #ff0000 1px solid; COLOR: ; BACKGROUND-COLOR: #ffff00" align="center" valign="middle"><strong>TEST</strong></td>
	</tr>
    </tbody>
</table>
--

Please note, I have verified 100% that this is an issue with Version 47.x on, as I went back to version 46.x in which printing background colors/styles work fine, clicking the Checkbox (display background colors/styles turns off/on background colors in vers. 46.x on.
Flags: needinfo?(webshaman)

Comment 3

a year ago
Created attachment 8772197 [details]
1286346.html

I tested the testcase, if I select the option "Print Background (colors & images)" in the Print Setup, I see the yellow table (it's white with this option disabled) and the yellow table is printed well.

Could you test with a fresh profile?
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(webshaman)
(Reporter)

Comment 4

a year ago
Hello,

Thank you, I tried with a fresh profile and it works ok (I can see/print color backgrounds). I still have questions, and another issues.

1.) What would be different between one profile and the other, that would not allow it to work in my old profile?  Was something changed in the old profile that suddenly caused it to stop working?  As, I don't remember changing anything, and then it's not working?

2.) Regarding printing & sizing, I've also found out that in Quirks mode (if I do not define a DOCTYPE, and just begin the page with <HTML> that will cause the page to display/print in Quirks mode), when I choose Page Setup->Shrink to Fit for sizing, it sizes the page larger, than if I am running NON-Quirks mode (for example if I send out a DOCTYPE to start the document).  This causes PDF scaling (sizing) issues as the page zooms out further, and prints to a higher page count (87 pages, instead of 73 pages) by doing that.  I prefer the much higher (bigger and easier to read) format of Quirks mode, but I'm not sure why it's doing that?  It doesn't bother me, as I send out all my documents that I've coded without a DOCTYPE, but just wondering, as at some point down the road that may cause a problem? Not sure, as it seems to work fine now?

Thank you,
-Brett

Comment 5

a year ago
I guess the issue is about bad prefs in about:config, especially about print prefs.

Can you try that:
1) type about:support in the location bar
2) click on the button to open the profile folder
3) find the file "prefs.js" and rename it to "prefs.js.old"
4) restart Firefox

Does it work?
Marking resolved per comment 4.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.