Intermittent toolkit/content/tests/widgets/test_videocontrols_audio_direction.html | application ran for longer than allowed maximum time

RESOLVED DUPLICATE of bug 1345350

Status

()

Toolkit
Video/Audio Controls
P1
normal
RESOLVED DUPLICATE of bug 1345350
2 years ago
10 months ago

People

(Reporter: Treeherder Bug Filer, Assigned: gbrown)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

Component: General → Video/Audio Controls
Chris, https://hg.mozilla.org/mozilla-central/rev/afb94913764c recently changed videocontrols.xml and likely caused this test to run a little bit longer? The change doesn't make sense to me as to why this test would time out. What do you think we should do here?
Blocks: 1273725
Flags: needinfo?(cpearce)
Priority: -- → P1
Jaws: I think it's unlikely my recent change regressed this.

Anthony: Is there someone in Taipei who can help make this test green?
Flags: needinfo?(cpearce)
Flags: needinfo?(ajones)
Ray - can you take a look see?
Flags: needinfo?(ajones) → needinfo?(ralin)

Comment 4

2 years ago
Sorry for the late reply.

I pushed two try on the weekend, one is latest revision[0] and the other is before Chris's patch[1]. It shows little chance to reproduce the failure which only one failure among dozens of M20 test. 
I can not figure out the reason at this moment, perhaps narrowed regression window could help.

[0] https://treeherder.mozilla.org/#/jobs?repo=try&revision=50cd402deb27
[1] https://treeherder.mozilla.org/#/jobs?repo=try&revision=3762bc2330d6
Flags: needinfo?(ralin)

Comment 5

2 years ago
15 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 7
* autoland: 4
* fx-team: 2
* try: 1
* mozilla-central: 1

Platform breakdown:
* android-4-3-armv7-api15: 15

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1286374&startday=2016-08-29&endday=2016-09-04&tree=all

Comment 6

2 years ago
16 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 7
* autoland: 6
* fx-team: 2
* mozilla-central: 1

Platform breakdown:
* android-4-3-armv7-api15: 16

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1286374&startday=2016-09-05&endday=2016-09-11&tree=all

Comment 7

2 years ago
12 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 7
* autoland: 3
* try: 1
* fx-team: 1

Platform breakdown:
* android-4-3-armv7-api15: 12

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1286374&startday=2016-09-12&endday=2016-09-18&tree=all

Comment 8

2 years ago
14 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 6
* autoland: 5
* fx-team: 2
* try: 1

Platform breakdown:
* android-4-3-armv7-api15: 14

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1286374&startday=2016-09-19&endday=2016-09-25&tree=all

Comment 9

2 years ago
7 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* autoland: 4
* mozilla-inbound: 2
* fx-team: 1

Platform breakdown:
* android-4-3-armv7-api15: 7

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1286374&startday=2016-09-26&endday=2016-10-02&tree=all
(Assignee)

Comment 10

2 years ago
There were many similar timeouts in Android mochitests in 2016-09, especially in Android Debug mochitest-20. In bug 1204281, we increased the number of Android mochitest test chunks, so that fewer tests were run in each chunk and each chunk ran faster -- no such timeouts since. 

I've been dup'ing these bugs to 1204281, but I'll leave this one open since there's been discussion -- is anyone still investigating / is there a particular test or change that is suspected of increasing the run time?
(Assignee)

Comment 11

a year ago
Recent failures reported here are being handled in bug 1345350.
Assignee: nobody → gbrown
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1345350

Comment 12

10 months ago
1 failures in 718 pushes (0.001 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* try: 1

Platform breakdown:
* android-4-3-armv7-api15: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1286374&startday=2017-06-26&endday=2017-07-02&tree=all
You need to log in before you can comment on or make changes to this bug.