Up/Down arrows do not work or don't work as expected

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Address Book & Contacts
P1
normal
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Ninoschka Baca, Assigned: Sean Su)

Tracking

Trunk
mozilla1.0
All
Windows ME
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ADT3])

(Reporter)

Description

16 years ago
Trunk build 2002-03-01: WinMe, Linux RH 6.1
haven't tried mac yet

Overview: Open a long mailing list so a scrollbar appears. Try and use the up or 
down arrow keys.

Actual Results: The list opens showing the last addresses in the list...
a. The up arrow on the scrollbar does not work at all. 
b. The down arrow quickly moves to the bottom of the list. 
Workaround: The only way to scroll through the list is to use the scrollbar 
itself slowly.

Expected Result: 
a. Selecting the up arrow should incrementally move up through the list
b. Selecting the down arrow should incrementally move down through the list
(Reporter)

Comment 1

16 years ago
Marking nsbeta1 because users will expect to use the arrow keys to traverse 
through a list. Currently they are pretty useless.
Keywords: nsbeta1

Comment 2

16 years ago
I would have nsbeta1-'d this if it had the same behavior as the compose window
(shift-tab and tab) to move up and down and the up arrow key to move up when the
top item is selected.  But the arrow keys never work.
Assignee: racham → ssu
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P1
Target Milestone: --- → mozilla1.0
(Reporter)

Updated

16 years ago
Blocks: 128661

Comment 3

16 years ago
Worksforme (build: 20020307) - I can scroll using the buttons, or the keys on
the keyboard.
(Assignee)

Comment 4

16 years ago
looks like it's working now.  marking as worksforme since I didn't do anything
to fix it.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

16 years ago
Trunk build 2002-03-13: WinMe
The problem is still appearing on my system.

Steps to reproduce:
1. Create a list with 10 entries
2. Select the list in the directory pane
3. Double click onto the list so it opens in the Mailing List dialog
4. Click onto the up arrow ontop of the scrollbar

Actual Results:
1. Clicking on the up arrow on the scrollbar and it does not move the list up
2. Hold and drag the scrollbar up and moves to the top of the list. Now click
onto the down arrow on the scrollbar and it immediately moves to the end instead
of incrementally moving down.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 6

16 years ago
Discussed in Mail News bug meeting. Decided to [ADT3] this bug.
Whiteboard: [ADT3]
(Reporter)

Updated

16 years ago
Blocks: 136757

Comment 7

16 years ago
Changing nsbeta1+ [adt3] bugs to nsbeta1- on behalf of the adt.  If you have any
questions about this, please email adt@netscape.com.  You can search for
"changing adt3 bugs" to quickly find and delete these bug mails.
Keywords: nsbeta1-

Comment 8

16 years ago
Changing nsbeta1+ [adt3] bugs to nsbeta1- on behalf of the adt.  If you have any
questions about this, please email adt@netscape.com.  You can search for
"changing adt3 bugs" to quickly find and delete these bug mails.
Keywords: nsbeta1+

Comment 9

16 years ago
Mac OS 9.2.2 English-North American
Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.2a) Gecko/20020913
Build ID 2002091309. 'Modern' theme installed.

Works for me.

Comment 10

16 years ago
Wfm: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.2b) Gecko/20020919

Comment 11

14 years ago
WFM in WinME using Moz nightly build 2004010311.

Comment 12

14 years ago
Re Comment 11, that was WFM using build 2004020311.

Updated

14 years ago
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.