Option to compress large attachments automatically (ZIP)

RESOLVED WONTFIX

Status

MailNews Core
Composition
P3
enhancement
RESOLVED WONTFIX
19 years ago
4 years ago

People

(Reporter: bruno, Unassigned)

Tracking

(Blocks: 2 bugs)

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: wontfix-addon-welcome)

(Reporter)

Description

19 years ago
Messenger should be able to compress with ZIP, attachment files which have a
weight more than [user choice] Ko...

It might be very appreciated by the users. Isn't it ?

Updated

19 years ago
Assignee: ducarroz → phil

Updated

19 years ago
Summary: ZIP attachment files autmatically options → [HELP WANTED] ZIP attachment files autmatically options
Target Milestone: M20

Comment 1

19 years ago
That might be useful, but I'd be nervous about all mail readers (and
users) being able to unzip attachments.

Anyway, I'll put this out on the HELP WANTED list in case someone wants to code
it up.

Comment 2

19 years ago
Reopen mail/news HELP WANTED bugs and reassign to nobody@mozilla.org

Updated

19 years ago
Whiteboard: HELP WANTED

Comment 3

19 years ago
Put HELP WANTED in the Status Whiteboard so the mozilla.org bug query finds them

Updated

19 years ago
QA Contact: lchiang → pmock

Comment 4

19 years ago
changing QA assigned to pmock@netscape.com

Updated

19 years ago
Keywords: helpwanted

Updated

19 years ago
Summary: [HELP WANTED] ZIP attachment files autmatically options → ZIP attachment files autmatically options
Whiteboard: HELP WANTED
Target Milestone: M20

Comment 5

18 years ago
>That might be useful, but I'd be nervous about all mail readers (and
>users) being able to unzip attachments.

Every mailer can open a zipped file with external program (like
PowerArchiver2001 - a freeware archiver with many format support). So I do not
see any problems here.

We also can just implement a call of an external program to zip the attachment.
I believe we do not have to implement the full zip algorithm.

Comment 6

18 years ago
Change QA-assign to fenella
QA Contact: pmock → fenella

Comment 7

17 years ago
To Esther..

Updated

17 years ago
QA Contact: fenella → esther

Updated

17 years ago
QA Contact: esther → trix

Comment 8

16 years ago
It seems like Mozilla have somekind of .zip support. Fx look at:
http://lxr.mozilla.org/mozilla/source/modules/libjar/nsZipArchive.cpp

Perhaps this could be used for zipping and unzipping attachments.

Updated

16 years ago
Blocks: 157566

Updated

16 years ago
Blocks: 178310
looks like work on this has begun in bug 180798

*** This bug has been marked as a duplicate of 180798 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
I can't read. 'options', not 'opens'. clearing dup status, sorry. (sigh)
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
QA Contact: trix → stephend

Updated

16 years ago
Summary: ZIP attachment files autmatically options → Option to ZIP large attachments autmatically

Comment 11

15 years ago
*** Bug 209273 has been marked as a duplicate of this bug. ***

Comment 12

15 years ago
Does anyone know where can be found information on the development, if any,
of these features.

Is this planned to be released in a future release?

Any informations would be greatly appreciated.
Pedro Madeira
(Creator of bug 209273)

Comment 13

14 years ago
We'd need to be very careful about this potential 'feature' -- I know of several
private ISP installations that are choosing to block/discard all .zip
attachments, since zip-format is now commonly used as a container for viruses.....  

Best not to have Mozilla do magical things under the covers, unless it's really
clear to a novice user what is being done, and why .... 

Comment 14

14 years ago
How's the status on this?

In reply to Comment #13 I suggest that Mozilla should by default NOT zip/unzip
attachments but could be selected by power users or administrators for their
users in such a way that only after testing this option would be enabled.

Believe me: This would make mozilla score big against other mail clients due to
the bandwidth gain achieved with a feature like this.

Best regards from Portugal,
Pedro Madeira
Product: MailNews → Core

Comment 15

12 years ago
*** Bug 345237 has been marked as a duplicate of this bug. ***

Comment 16

12 years ago
Tweaking summary to improve findability.

Some ideas from bug 345237 comment 0:
>  * Provide a button in the attachments pane (or elsewhere) that will compress
> attachments when clicked.
>  * Provide a preferences configuration section that allows the user to
> automatically have thunderbird compress attachments over xxx kb in size.
>  * Display a pop-up that requests the user to allow Thunderbird to compress all
> attachments when the sum total size of the attachments is larger than xxx kb.
>  * Have Thunderbird automatically compress large attachments without
> interaction when sending to users who use Thunderbird as well. 
>  * Have a "Compress Attachments and Send" button
>  * Provide a "Compress Attachments" toggle when selecting attachments in the
> file manager. 
Summary: Option to ZIP large attachments autmatically → Option to compress large attachments automatically (ZIP)
Filter on "Nobody_NScomTLD_20080620"
Status: REOPENED → NEW
QA Contact: stephend → composition
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Updated

8 years ago
Duplicate of this bug: 550769
--> This bug should be resolved "wontfix", in full appreciation of the idea (wonfix+want_addon, see bug 577944 and bug 522873).

This looks like a valid idea, and a good one indeed.
However, it's very unlikely that core developers will find time for this, and it's a complex feature that cannot be the default behaviour. As such, it would be a nice candidate for an extension.

N.B. There is an outdated addon for this feature: 
Auto Zip Attachments (https://addons.mozilla.org/thunderbird/4003)

A modified version for TB 3.1 has been posted here (no guarantees, but worked for me): http://www.megaupload.com/?d=1WDSFIJB
Whiteboard: wontfix+want_extension?
Blocks: 595629
Wontfix per comment 19...
Status: NEW → RESOLVED
Last Resolved: 16 years ago5 years ago
Keywords: helpwanted
Resolution: --- → WONTFIX
Whiteboard: wontfix+want_extension? → wontfix-addon-welcome
In reply to comment #19:
Your addons.mozilla.org "4003" link is outdated and gives me error 404 Not Found. The extension is now at https://addons.mozilla.org/en-US/thunderbird/addon/auto-zip-attachments/ and supports Thundderbird up to version 2.0.0.*; it does not support SeaMonkey.

Updated

4 years ago
Duplicate of this bug: 852095

Updated

4 years ago
See Also: → bug 852095
You need to log in before you can comment on or make changes to this bug.