Win10 Start Menu Tile wrong color

VERIFIED FIXED in Firefox 50

Status

defect
VERIFIED FIXED
3 years ago
4 months ago

People

(Reporter: jmjjeffery, Assigned: ktbee)

Tracking

Trunk
mozilla50
Dependency tree / graph

Firefox Tracking Flags

(firefox50 verified, firefox51 verified)

Details

Attachments

(1 attachment)

Start Menu Tile background changed color from 'Grey' to 'Light bluish' color

See discussion in the two blocking bugs relative to this matter.
(Assignee)

Updated

3 years ago
Assignee: nobody → kbroida
(Assignee)

Comment 1

3 years ago
This patch removes the VisualElementsManifest.xml file, which I found was breaking the start menu tile for some Windows 10 computers. Without it, firefox.VisualElementsManifest.xml still customizes Nightly's start menu tile for some Windows 10 computers. For others, it leaves the tile unaffected and the default background color and icon image show.

Review commit: https://reviewboard.mozilla.org/r/64258/diff/#index_header
See other reviews: https://reviewboard.mozilla.org/r/64258/
Attachment #8770976 - Flags: review?(jaws)
Attachment #8770976 - Flags: review?(jaws) → review+
Comment on attachment 8770976 [details]
Bug 1286511 - Fixes incorrect start menu tile color by removing VisualElementsManfiest.xml

https://reviewboard.mozilla.org/r/64258/#review61298

r=me for the file removal. I added rstrong as a reviewer since this touches the installer.

Do we need to do anything extra to have the installer remove this file if it was already installed? This hasn't left the Nightly channel yet so it won't affect DevChannel, Beta, or Release.
Attachment #8770976 - Flags: review?(robert.strong.bugs)
Comment on attachment 8770976 [details]
Bug 1286511 - Fixes incorrect start menu tile color by removing VisualElementsManfiest.xml

https://reviewboard.mozilla.org/r/64258/#review61306

Looks good and I visually verified that these build changes should do the right thing for our build packaging code.
Attachment #8770976 - Flags: review?(robert.strong.bugs) → review+
Component: Installer → Build Config
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
I have a patch to land and will land this.
Keywords: checkin-needed

Comment 5

3 years ago
Pushed by rstrong@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/36ea792c434b
Fixes incorrect start menu tile color by removing VisualElementsManfiest.xml. r=jaws, r=rstrong

Comment 6

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/36ea792c434b
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 50
I have reproduced this on Firefox nightly according to(2016-07-13)

Fixing bug is verified on Latest Nightly--Build ID: (20160908030434), User Agent: Mozilla/5.0 (Windows NT 10.0; rv:51.0) Gecko/20100101 Firefox/51.0


Tested OS-- Windows10 32bit
QA Whiteboard: [testday-20160909]
(Assignee)

Updated

3 years ago
Status: RESOLVED → VERIFIED
Also ,
Fixing bug is verified on Latest Developer Edition-- Build ID:(20160909004004),User Agent: Mozilla/5.0 (Windows NT 10.0; rv:50.0) Gecko/20100101 Firefox/50.0
Component: Build Config → General
Product: Firefox → Firefox Build System
Keywords: regression
Target Milestone: Firefox 50 → mozilla50
You need to log in before you can comment on or make changes to this bug.