Closed Bug 1286522 Opened 5 years ago Closed 5 years ago

Crash in EnterBaseline

Categories

(Firefox for Android Graveyard :: General, defect)

50 Branch
Unspecified
Android
defect
Not set
critical

Tracking

(firefox50 affected)

RESOLVED WORKSFORME
Tracking Status
firefox50 --- affected

People

(Reporter: sflorean, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-2cbca074-0b50-4898-96a7-073b42160713.
=============================================================

Environment: 
Device: Prestigio Grace X5 (Android 4.4.2);
Build: Nightly 50.0a1 (2016-07-12);

Steps to reproduce:
1. Go to http://flashadds.com; 
2. Go to Menu-Settings-Advanced; 

Expected result:
"Advanced" panel opens.

Actual result:
Firefox crashes.

Notes:
This is not reproducible all the time.
Is this something the JS team can investigate?
Flags: needinfo?(nihsanullah)
Flags: needinfo?(nihsanullah) → needinfo?(jdemooij)
I'm unable to reproduce this on my Galaxy S5, can you still reproduce this with recent Nightlies?

I looked at the crash dump, we're crashing at 72edb000. It looks like Baseline IC code, the first 2 instructions make sense but after that it's bogus. Maybe memory corruption somewhere? I can't say much more. Maybe you can try a debug build?

72edaff8:	e373007b 	cmn	r3, #123	; 0x7b
72edaffc:	1a00000b 	bne	0x72edb030
72edb000:	2f657231 	svccs	0x00657231          <=== ** CRASH **
72edb004:	75646f6d 	strbvc	r6, [r4, #-3949]!	; 0xfffff093
72edb008:	2f736532 	svccs	0x00736532
72edb00c:	656c6554 	strbvs	r6, [ip, #-1364]!	; 0xfffffaac
72edb010:	72746535 	rsbsvc	r6, r4, #222298112	; 0xd400000
72edb014:	73655379 	cmnvc	r5, #-469762047	; 0xe4000001
72edb018:	6e6f6939 	mcrvs	9, 3, r6, cr15, cr9, {1}
72edb01c:	6d736a2e 	vldmdbvs	r3!, {s13-s58}
72edb020:	e18020d1 	ldrd	r2, [r0, r1]
72edb024:	e599900c 	ldr	r9, [r9, #12]
72edb028:	e5990000 	ldr	r0, [r9]
72edb02c:	e12fff10 	bx	r0
72edb030:	e5999004 	ldr	r9, [r9, #4]
72edb034:	e5990000 	ldr	r0, [r9]
72edb038:	e12fff10 	bx	r0
Flags: needinfo?(jdemooij) → needinfo?(sorina.florean)
Hi, I cannot reproduce this on latest Nightlies, following the STR from description.
Device: Prestigio Grace X5 (Android 4.4.2).
Flags: needinfo?(sorina.florean)
(In reply to Sorina Florean [:sorina] from comment #3)
> Hi, I cannot reproduce this on latest Nightlies, following the STR from
> description.
> Device: Prestigio Grace X5 (Android 4.4.2).

Thanks for testing that. Let's close as WORKSFORME? Please reopen if you disagree :)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.