Traceback when using qimport bz

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
2 years ago
3 months ago

People

(Reporter: Callek, Unassigned)

Tracking

Details

(Reporter)

Description

2 years ago
callek@Centaurus:~/mozilla/hg/mozilla-central$ hg import bz:1227182
applying bz:1227182
** Unknown exception encountered with possibly-broken third-party extension progress
** which supports versions unknown of Mercurial.
** Please disable progress and try your action again.
** If that fixes the bug please report it to the extension author.
** Python 2.7.10 (default, Oct 14 2015, 16:09:02) [GCC 5.2.1 20151010]
** Mercurial Distributed SCM (version 3.5.1)
** Extensions loaded: color, progress, histedit, rebase, strip, mq, transplant, share, bundleclone, qimportbz, reviewboard, push-to-try
Traceback (most recent call last):
  File "/usr/local/bin/hg", line 43, in <module>
    mercurial.dispatch.run()
  File "/usr/local/lib/python2.7/dist-packages/mercurial/dispatch.py", line 30, in run
    sys.exit((dispatch(request(sys.argv[1:])) or 0) & 255)
  File "/usr/local/lib/python2.7/dist-packages/mercurial/dispatch.py", line 92, in dispatch
    ret = _runcatch(req)
  File "/usr/local/lib/python2.7/dist-packages/mercurial/dispatch.py", line 163, in _runcatch
    return _dispatch(req)
  File "/usr/local/lib/python2.7/dist-packages/mercurial/dispatch.py", line 895, in _dispatch
    cmdpats, cmdoptions)
  File "/usr/local/lib/python2.7/dist-packages/mercurial/dispatch.py", line 656, in runcommand
    ret = _runcommand(ui, options, cmd, d)
  File "/usr/local/lib/python2.7/dist-packages/mercurial/extensions.py", line 171, in closure
    return func(*(args + a), **kw)
  File "/usr/local/lib/python2.7/dist-packages/hgext/color.py", line 525, in colorcmd
    return orig(ui_, opts, cmd, cmdfunc)
  File "/usr/local/lib/python2.7/dist-packages/mercurial/dispatch.py", line 1013, in _runcommand
    return checkargs()
  File "/usr/local/lib/python2.7/dist-packages/mercurial/dispatch.py", line 982, in checkargs
    return cmdfunc()
  File "/usr/local/lib/python2.7/dist-packages/mercurial/dispatch.py", line 892, in <lambda>
    d = lambda: util.checksignature(func)(ui, *args, **cmdoptions)
  File "/usr/local/lib/python2.7/dist-packages/mercurial/util.py", line 792, in check
    return func(*args, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/mercurial/extensions.py", line 171, in closure
    return func(*(args + a), **kw)
  File "/usr/local/lib/python2.7/dist-packages/mercurial/util.py", line 792, in check
    return func(*args, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/hgext/mq.py", line 3515, in mqcommand
    return orig(ui, repo, *args, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/mercurial/util.py", line 792, in check
    return func(*args, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/mercurial/extensions.py", line 171, in closure
    return func(*(args + a), **kw)
  File "/usr/local/lib/python2.7/dist-packages/mercurial/util.py", line 792, in check
    return func(*args, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/hgext/mq.py", line 3487, in mqimport
    return orig(ui, repo, *args, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/mercurial/util.py", line 792, in check
    return func(*args, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/mercurial/commands.py", line 4277, in import_
    patchfile = hg.openpath(ui, patchurl)
  File "/usr/local/lib/python2.7/dist-packages/mercurial/hg.py", line 116, in openpath
    return url.open(ui, path)
  File "/usr/local/lib/python2.7/dist-packages/mercurial/url.py", line 508, in open
    return opener(ui, authinfo).open(url_, data)
  File "/usr/lib/python2.7/urllib2.py", line 431, in open
    response = self._open(req, data)
  File "/usr/lib/python2.7/urllib2.py", line 449, in _open
    '_open', req)
  File "/usr/lib/python2.7/urllib2.py", line 409, in _call_chain
    result = func(*args)
  File "/home/callek/mozilla/hg/version-control-tools/hgext/qimportbz/bzhandler.py", line 51, in bz_open
    num = int(req.get_host())
TypeError: int() argument must be a string or a number, not 'NoneType'


Command was: $ hg import bz:1227182

callek@Centaurus:~/mozilla/hg/mozilla-central$ hg --version
Mercurial Distributed SCM (version 3.5.1)
(see http://mercurial.selenic.com for more information)

Copyright (C) 2005-2015 Matt Mackall and others
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
callek@Centaurus:~/mozilla/hg/mozilla-central$ hg ident
8dd58892051a
(Reporter)

Comment 1

2 years ago
For the record,

callek@Centaurus:~/mozilla/hg/mozilla-central$ hg -R ~/mozilla/hg/version-control-tools/ ident
d23c45a50827 tip @

Comment 2

2 years ago
`hg import bz://1227182` works for me.

I can reproduce with `hg import bz:1227182`. I'm not sure if this is a bug in upstream Mercurial's URI parsing or something in bzimport not supporting "//" missing from the URI.
(Reporter)

Updated

3 months ago
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.