If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash accessing URL ftp://ftp.netfilter.org/pub/iptables/snapshot/ [@nsIndexedToHTML::OnDataAvailable]

VERIFIED DUPLICATE of bug 127003

Status

()

Core
Networking: FTP
--
critical
VERIFIED DUPLICATE of bug 127003
16 years ago
16 years ago

People

(Reporter: Mark Williamson, Assigned: asa)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.8+) Gecko/20020302

See TB3569952Z and TB3570006G
(Reporter)

Comment 1

16 years ago
Created attachment 72257 [details]
Ngrep dump of ftp conversation just before crash
-> Networking:ftp

nsIndexedToHTML::OnDataAvailable(nsIndexedToHTML * const 0x046829d0, nsIRequest
* 0x04682450, nsISupports * 0x00000000, nsIInputStream * 0x04683e64, unsigned
int 0, unsigned int 105) line 293 + 37 bytes
nsFTPDirListingConv::OnDataAvailable(nsFTPDirListingConv * const 0x04682740,
nsIRequest * 0x0467e8c0, nsISupports * 0x00000000, nsIInputStream * 0x04682fa0,
unsigned int 0, unsigned int 86) line 317 + 50 bytes
DataRequestForwarder::OnDataAvailable(DataRequestForwarder * const 0x0467e8c4,
nsIRequest * 0x04682d90, nsISupports * 0x00000000, nsIInputStream * 0x04682fa0,
unsigned int 0, unsigned int 86) line 358 + 52 bytes
nsOnDataAvailableEvent::HandleEvent() line 193 + 70 bytes
nsARequestObserverEvent::HandlePLEvent(PLEvent * 0x04681254) line 116
PL_HandleEvent(PLEvent * 0x04681254) line 590 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x0037c5a0) line 520 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x00180172, unsigned int 49358, unsigned int 0,
long 3655072) line 1071 + 9 bytes
USER32! 77e02e98()
USER32! 77e030e0()
USER32! 77e05824()
nsAppShellService::Run(nsAppShellService * const 0x015e79b0) line 308
main1(int 2, char * * 0x00304fa0, nsISupports * 0x00000000) line 1285 + 32 bytes
main(int 2, char * * 0x00304fa0) line 1625 + 37 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77e87d08()


*** This bug has been marked as a duplicate of 127003 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Component: Browser-General → Networking: FTP
QA Contact: doronr → benc
Resolution: --- → DUPLICATE

Comment 3

16 years ago
V: mc1, w98.
reopen if broken in 1.0
Status: RESOLVED → VERIFIED
Summary: Crash accessing URL ftp://ftp.netfilter.org/pub/iptables/snapshot/ → Crash accessing URL ftp://ftp.netfilter.org/pub/iptables/snapshot/ [@nsIndexedToHTML::OnDataAvailable]
You need to log in before you can comment on or make changes to this bug.