Closed Bug 1286674 Opened 4 years ago Closed 4 years ago

Font in text is using blurry grayscale antialiasing instead of sharp subpixel antialiasing

Categories

(Core :: Graphics: Text, defect, major)

50 Branch
x86_64
Windows 7
defect
Not set
major

Tracking

()

VERIFIED FIXED
mozilla50
Tracking Status
firefox49 --- unaffected
firefox50 --- verified

People

(Reporter: Virtual, Assigned: mstange)

References

Details

(Keywords: nightly-community, regression, Whiteboard: [gfx-noted][fixed by patch backout from bug #1012752])

Attachments

(2 files)

[Tracking Requested - why for this release]: Regression

STR:
1. Open some forums like for example - http://board.pl.ogame.gameforge.com/board790-z-ycia-uniwers-w/board264-dyskusje-i-dyplomacja/board1407-did-u68/
2. See that grayscale antialiasing is used instead of sharp subpixel antialiasing

Going to http://board.pl.ogame.gameforge.com/board790-z-ycia-uniwers-w/board264-dyskusje-i-dyplomacja/board1407-did-u68/1354881-rekordy-uni68/index6.html could produce the same issue, but only when the page is at the bottom, scrolling up fixes the issue
Whiteboard: https://www.google.com/url?q=https%3A%2F%2Fbugzilla.mozilla.org%2Fbuglist.cgi%3Ff1%3Dstatus_whiteboard%26o1%3Dnotsubstring%26emailtype1%3Dexact%26chfield%3D%255BBug%2520creation%255D%26emailassigned_to1%3D1%26query_format%3Dadvanced%26bug_status%3DUNCONF …
Whiteboard: https://www.google.com/url?q=https%3A%2F%2Fbugzilla.mozilla.org%2Fbuglist.cgi%3Ff1%3Dstatus_whiteboard%26o1%3Dnotsubstring%26emailtype1%3Dexact%26chfield%3D%255BBug%2520creation%255D%26emailassigned_to1%3D1%26query_format%3Dadvanced%26bug_status%3DUNCONF … → [gfx-noted]
Looks like we're failing to detect the layer as opaque. I've backed out bug 1012752 because I need some more time to investigate this.
Flags: needinfo?(mstange)
This is works for me, because of the backout of bug 1012752.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
Bug 1012752 not backed out yet.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Fixed by backout of culprit patch

(In reply to Carsten Book [:Tomcat] from bug #1012752 comment #36)
> https://hg.mozilla.org/mozilla-central/rev/440f999f965f
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Whiteboard: [gfx-noted] → [gfx-noted][fixed by patch backout from bug #1012752]
Status: RESOLVED → VERIFIED
Target Milestone: --- → mozilla50
Since this was fixed by a backout, I don't think we need to track this for 50.
Virtual_ManPL, can you reproduce this bug with the new try build from bug 1012752 at https://treeherder.mozilla.org/#/jobs?repo=try&revision=1f82832d45b2 ?
I've only got it to reproduce when I scrolled all the way to the bottom, and that part is fixed for me.
Flags: needinfo?(bernesb)
(In reply to Markus Stange [:mstange] from comment #9)
> Virtual_ManPL, can you reproduce this bug with the new try build from bug
> 1012752 at
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=1f82832d45b2 ?
> I've only got it to reproduce when I scrolled all the way to the bottom, and
> that part is fixed for me.

I can't reproduce the issue with this build.
Flags: needinfo?(bernesb)
Thank you for testing.
You need to log in before you can comment on or make changes to this bug.