Consider browser.showQuitWarning true being the default or other options

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
2 years ago
2 months ago

People

(Reporter: jkt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
As a user with lots of tabs open accel+w is really useful to close tabs however fairly often I also end up pressing shift too which closes all my tabs.

Could we consider adding a confirm dialog here even if it needs to be under a pref?
This feels like a frontend question so moving there.
Component: Keyboard: Navigation → Untriaged
Product: Core → Firefox
(Reporter)

Comment 2

2 years ago
It looks like this was a regression as certain versions of Firefox I have don't do this.
Works fine:
47 stable
49.0a2 dev edition
50.0a1 Nightly

So I guess it was a regression that was fixed, will close for now and check if it happens again.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

2 years ago
This is still occurring and it doesn't appear to be a feature per se (hitting q is too easy).
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 4

2 years ago
Looking into this as it's impacted my work enough :D.
Assignee: nobody → jkt
(Reporter)

Comment 5

2 years ago
Can we consider making browser.showQuitWarning pref be true by default preventing users from accidentally closing all their tabs when they might have music playing etc.
We could have a way to turn that off like the tab close warning.
There seems to be an option in about:preferences that isn't always present asking if we want to always show the warning, this case doesn't apply to that.
Assignee: jkt → nobody
Summary: Consider key_closeWindow providing a confirm dialog → Consider browser.showQuitWarning true being the default or other options

Updated

2 years ago
Component: Untriaged → Preferences
Comment hidden (me-too)

Comment 7

2 months ago
(In reply to Jonathan Kingston [:jkt] from comment #5)
> Can we consider making browser.showQuitWarning pref be true by default

No, because it was removed in bug 1438499. What would you like to do with this report?

(In reply to Jonathan Kingston [:jkt] from comment #3)
> (hitting q is too easy).

Bug 52821
Bug 550559
Flags: needinfo?(jkt)
(Reporter)

Comment 8

2 months ago
browser.warnOnQuit and browser.tabs.warnOnClose both seem to replace this and make this bug redundant now. Thanks Gijs.

So I don't think there is a reason to keep this at all, unless I am mistaken about some other setup.
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 months ago
Flags: needinfo?(jkt)
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

2 months ago
It looks like Bug 52821 could be resolved too right? I wanted to check given it's age and number of comments though.
Flags: needinfo?(gingerbread_man)
Flags: needinfo?(gijskruitbosch+bugs)

Comment 10

2 months ago
(In reply to Jonathan Kingston [:jkt] from comment #9)
> It looks like Bug 52821 could be resolved too right?

I can't test Ctrl+Q / Cmd+Q since I don't have access to Linux and Mac. But prior to bug 1438499, there was no warning when pressing Ctrl+Shift+Q with multiple tabs open, but now there is.
Flags: needinfo?(gingerbread_man)

Comment 11

2 months ago
(In reply to Jonathan Kingston [:jkt] from comment #9)
> It looks like Bug 52821 could be resolved too right? I wanted to check given
> it's age and number of comments though.

I think there's a case for having a separate thing specifically for the quit shortcut vs. other ways of quitting (Chrome does!), and none of the work that's either landed or is ongoing will be addressing that. So I wouldn't touch that bug.
Flags: needinfo?(gijskruitbosch+bugs)
You need to log in before you can comment on or make changes to this bug.