Closed Bug 1286892 Opened 4 years ago Closed 4 years ago

Inspector sidebar tabs now have a bigger font-size

Categories

(DevTools :: Shared Components, defect, P1)

defect

Tracking

(firefox50+ verified)

VERIFIED FIXED
Firefox 50
Iteration:
50.4 - Aug 1
Tracking Status
firefox50 + verified

People

(Reporter: ntim, Assigned: evanxd)

References

Details

(Keywords: regression, Whiteboard: [reserve-html])

Attachments

(3 files, 2 obsolete files)

No description provided.
Keywords: regression
Attached image Before
Attached image After bug 1259819
[Tracking Requested - why for this release]: Visual regression
Whiteboard: [devtools-html] [triage]
Flags: qe-verify+
Priority: -- → P3
QA Contact: alexandra.lucinet
Whiteboard: [devtools-html] [triage] → [reserve-html]
Tracking 50+ for this visual regression.
Current the font size is 12px[1]. Tracking code for the origin font size(before Bug 1259819).

[1]: https://github.com/mozilla/gecko-dev/blob/master/devtools/client/shared/components/tabs/tabs.css#L50-L58
Assignee: nobody → evan
Status: NEW → ASSIGNED
Attached patch bug-1286892.patch (obsolete) — Splinter Review
Hi Tim,

Could you help to review the patch?

Thanks.
Attachment #8775523 - Flags: review?(ntim.bugs)
Comment on attachment 8775523 [details] [diff] [review]
bug-1286892.patch

Review of attachment 8775523 [details] [diff] [review]:
-----------------------------------------------------------------

Can you remove the font size rule altogether ?
Attachment #8775523 - Flags: review?(ntim.bugs)
Attachment #8775523 - Attachment is obsolete: true
Attached patch bug-1286892.patch (obsolete) — Splinter Review
Hi Tim,

I updated the patch for your comments.

Please help to review the patch.

Thanks.
Attachment #8775863 - Flags: review?(ntim.bugs)
Comment on attachment 8775863 [details] [diff] [review]
bug-1286892.patch

Review of attachment 8775863 [details] [diff] [review]:
-----------------------------------------------------------------

So, this needs rebasing because bug 1290003 landed (which fixed the font-size on OSX, but broke it on Windows).
Attachment #8775863 - Flags: review?(ntim.bugs) → review+
Attached file 1286892.patch
Rebased it and landing today to make it for merge
Attachment #8775863 - Attachment is obsolete: true
Attachment #8776103 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/fa9e9291bfe3
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 50
Iteration: --- → 50.4 - Aug 1
Priority: P3 → P1
(In reply to Gabriel Luong [:gl] (ΦωΦ) from comment #10)
> Created attachment 8776103 [details]
> 1286892.patch
> 
> Rebased it and landing today to make it for merge

Thanks for the rebase work, Gabriel.
Reproduced on Nightly 50.0a1 (2016-07-18), OS X 10.11.
Verified fixed FX 50.0a2 (2016-08-05).
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Version: unspecified → Trunk
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.