btrviper.com - Image maps completely unrecognized - use ID instead of NAME

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
17 years ago
3 years ago

People

(Reporter: Curtis Priest, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.7) Gecko/20011221
BuildID:    2001122106

The summary says it all. It treats the image map like a plain image, not
allowing me to click any of the links.

I had Mozilla 0.9.8 installed but it wouldn't let me see any of my mail or news
folders so I had to go back to 0.9.7. Therefore I don't know if this bug exists
in later versions or not.

Reproducible: Always
Steps to Reproduce:
1. Go to the URL


Actual Results:  It wouldn't let me click on the menu options like I can in
Netscape and IE.

Expected Results:  It should have let me click on certain parts of the image as
links.
The page nests elements wrong:
<center><map></center><area /><area />...</map>
->te
Assignee: pavlov → doronr
Status: UNCONFIRMED → NEW
Component: ImageLib → US General
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: tpreston → zach
Version: other → unspecified

Comment 2

16 years ago
This is once again a problem.  I downloaded Mozilla 1.2 (final) for Win32.  I
then uninstalled Mozilla 1.1 (final) and installed 1.2 fresh.  I can no longer
click any links in the image map at http://www.ebay.com/ - for instance the
"search" and "services" and "my ebay" links do not work there at the top of the
page.  This had been working just fine in Mozilla 1.1.

I am currently running:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2) Gecko/20021126
freiheit@syntheticdimension.net, that's a 1.2-specific problem (bug 182292)
OS: Windows 2000 → All

Updated

16 years ago
Summary: Image maps completely unrecognized → btrviper.com - Image maps completely unrecognized

Comment 4

15 years ago
tech evang june 2003 reorg
Assignee: doron → english-us
QA Contact: zach → english-us

Comment 5

15 years ago
Image Maps still not working in Mozilla 1.4.  I used XHTML 1.1 with the
following code, but mozilla only recognized it as an image and not the maps. 
Firebird 0.6.1 also failed.  MSIE tested okay.

<img alt="test image maps"  src="Layout01.png" style="width: 370px; height:
700px; border: 0px;" usemap="#linkmap" />
<map id="linkmap">
<area alt="first map" shape="rect" coords="20, 520, 105, 535"
href="http://www.geocities.com/mums2mums_club/" />
<area alt="second map" shape="rect" coords="20, 545, 105, 560"
href="http://clubmums2mums.proboards22.com/" />
</map>

Comment 6

15 years ago
they use id instead of name in the map. see
<http://www.w3.org/TR/html401/struct/objects.html#edef-MAP>

bugzilla is too slow to be useful. I will try to remember to research this in
more detail later. The spec says name, not id but really and truely, i would
hope it would work with id anyway. jst ? caillon ? opinions?

Summary: btrviper.com - Image maps completely unrecognized → btrviper.com - Image maps completely unrecognized - use ID instead of NAME

Comment 7

15 years ago
I thought mozilla is compliant with W3C's XHTML 1.0/1.1, guess that's just an
illusion, for now.  By what I understood, the W3C's XHTML specs has deprecated
NAME in favor of ID.
http://www.w3.org/TR/xhtml-modularization/abstract_modules.html#s_imapmodule

Comment 8

15 years ago
Victor, I don't think we support XHTML 1.1 but we do support XHTML 1.0. If you
send your page as text/html we will however treat your page as HTML. This is a
problem with using XHTML as text/plain which I do not recommend.

You have reverted the page to the old form which has invalid nested tags and
which still do not work in Mozilla. 

<http://validator.w3.org/check?uri=http%3A%2F%2Fbtrviper.com%2Fviper.html&doctype=%28detect+automatically%29&charset=iso-8859-1+%28Western+Europe%29>

Comment 9

15 years ago
Hi Bob, thanks for clarifying the XHTML 1.1 issues with Mozilla.  On a side note
however, I am in no way affiliated nor have any relations with the btviper.com
website.  I am just testing Mozilla 1.4 with XHTML 1.0 strict and XHTML 1.1
code.  I use Amaya 8.1b to generate the XHTML code and validated it with the W3C
XHTML 1.0 strict and 1.1 Validator.  It just surprises me that Mozilla is not
recognizing "ID" in replacement of "NAME" in client-side image map which W3C
proposes in XHTML 1.x. Since this is a bug reported already filed and is related
to the issue, I added my observations and voted for it to be fixed. (^_^)

Comment 10

10 years ago
this old bug still exists in FireFox 2
one must still use name attribute on map
in xhtml docs  even though iot has been
long deprecated .....  
why not accept id attribute as other browsers
and the w3 spec do .... try to move to 21st century

designers want to move on with clean code, not
redundant artifacts like name attribute !!! 

Comment 11

8 years ago
URL in comment 0 is WFM using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

Comment 12

8 years ago
The XHTML+RDFa 1.0 standard doesn not allow the use of the name attribute on a map element, so there is no way to currently have imagemaps work while validating, because it's not possible to reference the id attribute from the usemap attribute.

Comment 13

8 years ago
That's all well and good, but this bug certainly seems to be FIXED. At least, the site is functional. (I don't much care whether it validates.)
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.