Closed Bug 1287045 Opened 6 years ago Closed 6 years ago

Resize popup in WebExtension

Categories

(WebExtensions :: Untriaged, defect)

47 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1215025

People

(Reporter: brcontainer, Unassigned)

Details

Attachments

(1 file)

Attached image opera.png
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.106 Safari/537.36 OPR/38.0.2220.41

Steps to reproduce:

Note: Issue from Firefox 47 and Firefox Developer 49.0a2

I have a simple extension with this contents:

popup.html

    <!DOCTYPE html>
    <html>
        <head>
            <title>Firefox Bug</title>
            <meta charset="utf-8">
            <script type="text/javascript" src="popup.js"></script>
            <link rel="stylesheet" type="text/css" href="popup.css">
        </head>
        <body>
            <div id="foo">Empty</div>
        </body>
    </html>

popup.css

    html, body {
        margin: 0;
        padding: 0;
        max-height: 100%;
        min-height: 100px;
    }

    body {
        min-width: 300px;
    }

    .visible {
        display: block !important;
    }

    #foo {
        background-color: #c0c0c0;
        margin: 20px 0;
        height: 400px;
        display: none;
    }

popup.js

    window.onload = function() {
        setTimeout(function() {
            var foo = document.getElementById("foo");

            if (foo) {
                foo.className += " visible";
            }
        }, 2000);
    };

    


Actual results:

If dynamic content is injected in DOM (.innerHTML) and is bigger the popup no resize.


Expected results:

popup resize by size content like Chrome and Opera browsers (see attachmentes)
Component: Untriaged → WebExtensions
Product: Firefox → Toolkit
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1215025
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.