Closed Bug 128707 Opened 18 years ago Closed 18 years ago

"Internet Keywords" should use "default search engine"

Categories

(SeaMonkey :: Search, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 53171

People

(Reporter: johan.walles, Assigned: samir_bugzilla)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020214
BuildID:    

Enable "Internet Keywords" and type something that is sent off to a search
engine.  The search engine used should be the one I have selected as the
"default search engine" in the "Internet Search" preferences.


Reproducible: Always
Steps to Reproduce:
1. Open preferences, under navigator->internet search, choose Google as your
default search engine.
2. Enable "internet keywords" in navigator->smart browsing.
3. Type "magic labero" in the URL bar.

Actual Results:  The search gets sent to search-intl.netscape.com.


Expected Results:  The search should have been sent to Google.
dup of bug 53171. Note that search and Internet Keywords are different things,
though netscape's IK server falls back to search if it finds no keyword things
(afaiu)

*** This bug has been marked as a duplicate of 53171 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
V
QA Contact: claudius → benc
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.