Closed Bug 1287176 Opened 4 years ago Closed 4 years ago

Status file not written for staging errors

Categories

(Toolkit :: Application Update, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla51
Tracking Status
firefox47 --- unaffected
firefox48 --- unaffected
firefox49 --- unaffected
firefox-esr45 --- fixed
firefox50 + fixed
firefox51 --- fixed

People

(Reporter: robert.strong.bugs, Assigned: robert.strong.bugs)

References

Details

(Keywords: regression)

Attachments

(2 files, 7 obsolete files)

This is fallout from bug 1168743
Attached patch bug1287176 (obsolete) — Splinter Review
Attachment #8771502 - Flags: review?(spohl.mozilla.bugs)
Attachment #8771502 - Flags: review?(spohl.mozilla.bugs) → review+
I need to also update tests and will submit a test patch after I have finished.
Attached patch client code - patch in progress (obsolete) — Splinter Review
Attachment #8771502 - Attachment is obsolete: true
Attached patch test code - patch in progress (obsolete) — Splinter Review
I rat holed quite a bit on this but I *think* this should be it.
Attached patch client code rev1 (obsolete) — Splinter Review
I tried to keep the client changes to a minimum except for comments.
Attachment #8780457 - Attachment is obsolete: true
Attachment #8780458 - Attachment is obsolete: true
Attachment #8780462 - Flags: review?(mhowell)
Attached patch test code rev1 (obsolete) — Splinter Review
Forgot to revert var DEBUG_AUS_TEST = true; back to false
Attachment #8780463 - Attachment is obsolete: true
Attachment #8780463 - Flags: review?(mhowell)
Attachment #8780464 - Flags: review?(mhowell)
Attached patch client code rev1 (obsolete) — Splinter Review
There was a trailing space in a comment in the previous patch
Attachment #8780462 - Attachment is obsolete: true
Attachment #8780462 - Flags: review?(mhowell)
Attachment #8780473 - Flags: review?(mhowell)
marAppInUseStageSuccessComplete_unix.js failed in that try push on both Mac and Linux, with:
[checkPostUpdateAppLogFinished : 73] the update manager updateCount attribute should equal the expected value - 1 == 2

I'll review after that's fixed.
Flags: needinfo?(robert.strong.bugs)
Attached patch client code rev2Splinter Review
Attachment #8780464 - Attachment is obsolete: true
Attachment #8780473 - Attachment is obsolete: true
Attachment #8780464 - Flags: review?(mhowell)
Attachment #8780473 - Flags: review?(mhowell)
Flags: needinfo?(robert.strong.bugs)
Attachment #8780600 - Flags: review?(mhowell)
Attachment #8780601 - Flags: review?(mhowell)
Attachment #8780600 - Flags: review?(mhowell) → review+
Attachment #8780601 - Flags: review?(mhowell) → review+
Pushed by rstrong@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/10819baa58fc
client code - Status file not written for staging errors. r=mhowell
https://hg.mozilla.org/integration/mozilla-inbound/rev/49a53da6979c
test code - Status file not written for staging errors. r=mhowell
https://hg.mozilla.org/mozilla-central/rev/10819baa58fc
https://hg.mozilla.org/mozilla-central/rev/49a53da6979c
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
Can/should we uplift this to 50 (seems it's also affected)?
Flags: needinfo?(robert.strong.bugs)
[Tracking Requested - why for this release]:
This fixes a regression where update staging failures aren't handled properly.
Flags: needinfo?(robert.strong.bugs)
(In reply to Andrew Overholt [:overholt] from comment #14)
> Can/should we uplift this to 50 (seems it's also affected)?
After it bakes on nightly for a couple of days.
Tracked since it's a recent regression in 50.
Comment on attachment 8780600 [details] [diff] [review]
client code rev2

Approval Request Comment
[Feature/regressing bug #]: Bug 1168743
[User impact if declined]: Failed stage updates won't be handled properly
[Describe test coverage new/current, TreeHerder]: This has baked on nightly for a few days, the updated tests are thorough, and I've verified this locally.
[Risks and why]: It is possible that I might have missed a case this should handle but I spent a decent amount of time verifying all of the cases this needs to handle are handled. Also, the current fallbacks should prevent breaking updates as it did for this case.
[String/UUID change made/needed]: None
Attachment #8780600 - Flags: approval-mozilla-aurora?
No longer blocks: 1291985
Comment on attachment 8780600 [details] [diff] [review]
client code rev2

Improves our handling of failed staged updates, stabilized on Nightly for a week, Aurora50+
Attachment #8780600 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.