Deploy TestPilot 2016-07-15

RESOLVED FIXED

Status

Cloud Services
Operations: Deployment Requests
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: clouserw, Assigned: poiegas)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Hello!  Test Pilot has been tagged and is ready to deploy to staging.  Once it's verified on staging we should push to production.

Tag:  https://github.com/mozilla/testpilot/releases/tag/2016-07-15

Updated

2 years ago
Assignee: nobody → dthorn
deployed to stage
Status: NEW → ASSIGNED
Summary: Please deploy Test Pilot → Deploy TestPilot 2016-07-15
Update on deploy plan: 

- softvision found a few issues. 
- Patch will be created, and new tag: 2016-07-15-1
- This should be rolled out to stage when ready
  - have somebody in #testpilot to verify 
- Once verified, roll it out to prod tomorrow morning 8am PST.
- reassign this bug to paul @ softvision for verification
new tag was deployed to stage
This looks good! Please move to production.

Once live on production, please NI and assign to paul.oiegas@softvision.ro for verification.

Thanks Daniel!
Flags: needinfo?(dthorn)
pushing to production
Flags: needinfo?(dthorn)
Deployed to production, please test.
Assignee: dthorn → paul.oiegas
Flags: needinfo?(paul.oiegas)
(In reply to Ciprian Muresan [:cmuresan] from comment #6)
> Here is a list of the issues we found during our testing:
> https://github.com/mozilla/testpilot/issues/1091
> https://github.com/mozilla/testpilot/issues/1092
> https://github.com/mozilla/testpilot/issues/1093
> https://github.com/mozilla/testpilot/issues/1094
> https://github.com/mozilla/testpilot/issues/1095
> https://github.com/mozilla/testpilot/issues/1098
> https://github.com/mozilla/testpilot/issues/1100
Thanks cmuresan. We decided that none of these were show-stoppers for the deployment and we'll address them in our Friday triage.
Public server deploy testing was performed yesterday an no major issues observed except https://github.com/mozilla/testpilot/issues/1101 . Still, this may be related to our environment setup since the dev team managed to reproduce it just once. Further investigations will be performed.
Flags: needinfo?(paul.oiegas)
I'm going to close this as resolved. If we need another deployment (comment 10) we can open another bug.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.