Firefox - very slow page loading

RESOLVED INCOMPLETE

Status

()

Firefox
Untriaged
RESOLVED INCOMPLETE
a year ago
4 months ago

People

(Reporter: Big Muscle, Unassigned)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

a year ago
Created attachment 8771668 [details]
Mozilla Firefox - slow loading.mp4

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160623154057

Steps to reproduce:

Webpages loading in Firefox is very slow. It takes several seconds to connect to the website and when the website starts to appear, it takes several seconds to display all content. It behaves like I would be on very slow connection.

But when I open different browser (e.g. Edge, Internet Explorer etc.), all websites open immediately. I write URL, press ENTER and all content is loaded instantly. E.g. I see that Firefox takes long time to connect to website, I open different browser to load the same website and this browser loads the website immediately - even before Firefox!

I use Firefox on several computers (at work and at home) and this problem happens on all computers! Although I like the Firefox features very much, I'm thinking about changing the browser, because it limits browsing experience a lot. I have 100 Mbps connection and the Firefox works like I had 1 kbps.

Please, do not point me to clean/restore my profile. I did it milliontimes, maybe it helps but for several minutes only. Then Firefox starts to be slow as hell again.

I'm attaching example video to demonstrate the wrong behaviour.



Expected results:

Firefox should display the requested content immediately. Like other browsers do.
(Reporter)

Comment 1

a year ago
Created attachment 8771669 [details]
Microsoft Edge - fast loading.mp4

I'm attaching the video that show how Microsoft Edge loads the same website immediately.

Comment 2

a year ago
Do you have the issue with every website you visit? Do you have a proxy at home/work?
Flags: needinfo?(bigmuscle)
(Reporter)

Comment 3

a year ago
Yes, it happens with every website, but the more complex site it is, the more noticable it is.
If I try e.g. www.mapy.cz, Edge displays the map immediately, Firefox starts loading and when the website is loaded, it takes another time to slowly display the map.

I don't have proxy.

Comment 4

a year ago
It's weird because if you have the issue at home and at work, Firefox is probably used on different machines and networks.

Is it the same ISP at home and work?
(Reporter)

Comment 5

a year ago
ISP is different and computers are different too. Both computers have Win10.

I'm also noticing that Firefox uses around 30% CPU during the website loading.
The question is why everything works correctly in other browsers.
I tested on Win 10 x 64 and I can't reproduce it with FF 47 and Nightly 50.0a1.

Can you please download the Firefox Nightly from here: https://nightly.mozilla.org/ and retest the problem.

If you still have the issue please create a new profile, you have the steps here:https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles?redirectlocale=en-US&redirectslug=Managing-profiles#w_starting-the-profile-manager

Please test if the issue can be reproduced in the safe mode of Firefox: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
(Reporter)

Comment 7

a year ago
I did several experiments and the slowness (and high CPU usage during page loading) appears in the safe mode too. I have not tested nightly build yet.

To creating new profile... as I said in the beginning, it makes no sense to create the new profile. Altough it may solve the problem for several minutes, it starts appearing again. Generally, I think that "create new profile" is always bad advice, because it does not solve anything but it only tries to bypass some internal problem. If Firefox cannot functional properly due to something wrong in the profile, such bug should be fixed so Firefox can deal with it correctly. (e.g. if Firefox crashes, it is not due to the corrupted profile, but due to an unhandled exception in the code itself).

Comment 8

a year ago
Some bugs are due to wrong prefs or corrupt files in the profile, that's why testing with a new profile is recommended. Safe mode is recommended too to check add-ons are not faulty.
Ofc, if the bug is in the Firefox code, a new profile will not fix it.
Hi,
Marking this as Resolved: Incomplete due to the lack of response from the reporter.
If the issue is still reproducible with the latest Firefox version, feel free to reopen the bug with more information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 10

a year ago
(In reply to Loic from comment #8)
> Some bugs are due to wrong prefs or corrupt files in the profile, that's why
> testing with a new profile is recommended. Safe mode is recommended too to
> check add-ons are not faulty.
> Ofc, if the bug is in the Firefox code, a new profile will not fix it.

This is abolutely not right. If some files/prefs/configs are corrupted and the application is not able to handle it, then it is bug in the application.

However, after several months, I can now confirm that this bug is still present. And I even read many reports about bad Firefox performance.

Now, I can add the following:
- currently on Firefox 64-bit 49.0.2
- no add-ons
- Windows 10 x64 10.0.10586
- 16 GB RAM, 4-core CPU
- when browsing internet archives with large image scans, Firefox eats about 4 GB RAM in several hours and then message "Application eats too much memory" appears. After several minutes, Firefox is automatically killed by system (it probably caches all images forever)
- randomly, but very often, Firefox starts using too much CPU (about 40% during simple page loading)
- sometimes this high CPU usage remains even when all tabs are closed and only FireFox restart solves the problem
- the original "slowness" problem seems to be related to Firefox uptime - the longer time Firefox is running, the slower it is
Thanks Big Muscle for your update. Can you please download the Firefox Nightly from here: https://nightly.mozilla.org/ and retest the problem.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INCOMPLETE → ---
Any news about this issue Big Muscle?
(Reporter)

Comment 13

a year ago
I'm still trying to evaluate it, but:

- the original "slowness" problem does not seem to be noticeable with Nightly 53
- I cannot say anything about RAM usage yet
- having several tabs with flash content makes the Firefox very laggy (I know it is very rare situation and bad performance comes from the Adobe Flash, but it seems to be weird that external plugin influences whole application)
Thanks for your reply, I think the best way to continue with this is to mark this as Resolved: Incomplete until you will come with additional about this issue. Please note that the bug it won't be removed and you will be able to update it or reopen whenever you want. Thanks once again for you help.
Status: REOPENED → RESOLVED
Last Resolved: a year agoa year ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 15

11 months ago
So after some time, I can confirm that there is some memory problem.

Current setup:
Windows 10 64-bit build 14393.693
Firefox Nightly 64-bit 54.0a1
12 GB RAM

After some time, Firefox eats about 4 GB RAM (exactly 4 573 208 kB) then Windows displays dialog "Application Nightly eats too much resources...", after about a minute, the process is killed (there were still free about 5 GB RAM at this time)

It is reproducable at this page: http://www.portafontium.eu/iipimage/30067284 (and go through the images, it takes some time, I had to go through approx. 400 pages, then memory goes too high, performance of Firefox is degraded and it crashes).

Comment 16

11 months ago
Can you please capture a performance profile? You can get more info about how to install and use the Cleopatra add-on (that helps you get the performance profile) by going to:
https://new.cleopatra.io/
You need to install the add-on, start recording your profile while you are reproducing the actions that eats about 4 GB RAM, after you reproduced the issue please attach the profile to this bug. Thanks
(Reporter)

Comment 17

10 months ago
(In reply to ovidiu boca[:Ovidiu] from comment #16)
> Can you please capture a performance profile? You can get more info about
> how to install and use the Cleopatra add-on (that helps you get the
> performance profile) by going to:
> https://new.cleopatra.io/
> You need to install the add-on, start recording your profile while you are
> reproducing the actions that eats about 4 GB RAM, after you reproduced the
> issue please attach the profile to this bug. Thanks

I'll do it. I just apologize for my late answer, I didn't have much time to do it yet.
I am currently at Firefox 55 and I must say that it behaves weird - it very often takes 100% CPU (or just one complete CPU core), I very often see a message "This website slows down your browser" and I can't even close the tab nor click anything on that page etc.
(Reporter)

Comment 18

7 months ago
After experiencing a lot of unusability bugs in Firefox Nightly, I was forced to "downgrade" back to Firefox v53.0.2. I must confirm that the "slow-page loading bug" is still there. The webpages that load instantly in other browsers, take several seconds to load in Firefox. It seems that problem is not visible after Firefox startup, but it starts appearing after some time of usage.

I installed mentioned Cleopatra add-on and recorded a few minutes. I'm adding it to the attachments above. I hope it helps. Let me know if I need to set up or record something different.
Flags: needinfo?(bigmuscle)
(Reporter)

Comment 19

7 months ago
Created attachment 8868403 [details]
Firefox 2017-05-16 15.37 profile.sps.json.gz
Unfortunately, profiles captured on non-Nightly builds aren't super useful, because the stacks are different. Are you able to re-capture using Nightly?
Flags: needinfo?(bigmuscle)
(Reporter)

Comment 21

4 months ago
I'm sorry for not responding here for a longer time. I gave it up, the performance of the Firefox is so bad, so I decided to go to the different browser. I was really tired of the bad performance that happens on all of my computers.

On the other side, I decided to give a try to Firefox Nightly 57. My first impression was that it was really fast and website loaded much quicker. But it was really only the first impression :( because all of the performance problems still exist - websites load very slowly after tens minutes of uptime (it takes some time to load the website and another time to render it), load/save dialog opens for tens of seconds etc. etc. Other browsers don't have any of these problems. Sorry.
Flags: needinfo?(bigmuscle)
You need to log in before you can comment on or make changes to this bug.