Closed Bug 1287278 Opened 3 years ago Closed 3 years ago

dropmarker-icon direction is wrong in RTL locales on Linux

Categories

(Core :: Widget: Gtk, defect, P1)

42 Branch
All
Linux
defect

Tracking

()

VERIFIED FIXED
mozilla52
Tracking Status
firefox47 --- wontfix
firefox48 --- wontfix
firefox49 --- wontfix
firefox-esr45 --- wontfix
firefox50 --- fixed
firefox51 --- verified
firefox52 --- verified

People

(Reporter: magicp.jp, Assigned: m_kato)

References

Details

(Keywords: regression, Whiteboard: tpi:+)

Attachments

(3 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20160715063552

Steps to reproduce:

1. Start any version Firefox in RTL locales on Linux
2. Open "about:addons"
3. Check header-utils-btn


Actual results:

dropmarker-icon points to the left.


Expected results:

dropmarker-icon should point to the bottom.
Has STR: --- → yes
Component: Untriaged → Theme
OS: Unspecified → Linux
Hardware: Unspecified → All
hey jaws, 
can I work on this ?
Flags: needinfo?(jaws)
Yes, you can work on it but I will wait until you upload a patch for this bug before I assign it.
Flags: needinfo?(jaws)
looks like the .urlbar-history-dropmarker is in the same situation for rtl. Jaws, can you please tell me which will be the best place for this to start ?
Flags: needinfo?(jaws)
and how do I test my changes, after modifying the code how do I build firefox for rtl locale or how do I make the whole browser in rtl to see my changes ?
I'd first see whether moz_gtk_combo_box_entry_button_paint() is the function involved.

I'm not sure what's required for RTL, but it shouldn't need a separate build.
Try searching for a pref to force RTL.  If no luck there, try setting up a locale for a RTL language, and running the browser in that locale.
(In reply to Karl Tomlinson (:karlt) from comment #6)
> I'd first see whether moz_gtk_combo_box_entry_button_paint() is the function
> involved.
No idea about those techs 
> I'm not sure what's required for RTL, but it shouldn't need a separate build.
> Try searching for a pref to force RTL.  If no luck there, try setting up a
> locale for a RTL language, and running the browser in that locale.
Found an awesome solution from Julian Descottes. Here it is:
create a new string on about:config "intl.uidrection.en" and set the value to "rtl". 
Done, no extra add-ons needed.

Can you/anyone tell me where the value of -moz-appearance: toolbarbutton-dropdown; is defined ?
I mean the value of "toolbarbutton-dropdown" 
because if I uncheck this on the browser toolbox the dropmaker icon seems to be okay but the urlbar gets a little bit higher.
I don't know much about the LookAndFeel for GTK. karlt reviewed some of that work in bug 627699 so redirecting to him.
Flags: needinfo?(jaws) → needinfo?(karlt)
Priority: -- → P1
Whiteboard: tpi:+
Assignee: nobody → m_kato
Comment on attachment 8795641 [details]
Bug 1287278 - dropmaker-icon direction is wrong in RTL locale on Linux.

https://reviewboard.mozilla.org/r/81628/#review84008

::: widget/gtk/gtk3drawing.cpp:1266
(Diff revision 1)
> -        arrow_type = (arrow_type == GTK_ARROW_LEFT) ?
> -                         GTK_ARROW_RIGHT : GTK_ARROW_LEFT;
> +        if (arrow_type == GTK_ARROW_LEFT) {
> +            arrow_type = GTK_ARROW_RIGHT;
> +        } else if (arrow_type == GTK_ARROW_RIGHT) {
> +            arrow_type = GTK_ARROW_LEFT;
> +        }

> Bug 1287278 - dropmaker-icon direction is wrong in RTL locale on Linux. r?karlt

Please change the commit message to describe what the patch does to fix the bug.
"change only right arrows to left arrows when direction is RTL"


https://developer.mozilla.org/en-US/docs/Mercurial/Using_Mercurial#Commit_Message_Conventions
Comment on attachment 8795641 [details]
Bug 1287278 - dropmaker-icon direction is wrong in RTL locale on Linux.

https://reviewboard.mozilla.org/r/81628/#review84010

Thanks for diagnosing and fixing this!
Attachment #8795641 - Flags: review?(karlt) → review+
Blocks: 1023004
Keywords: regression
Pushed by m_kato@ga2.so-net.ne.jp:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5ee00c8709ee
dropmaker-icon direction is wrong in RTL locale on Linux. r=karlt
https://hg.mozilla.org/mozilla-central/rev/5ee00c8709ee
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Hello magicp, could you please verify this issue is fixed as expected on a latest Nightly build? Thanks!
Flags: needinfo?(magicp.jp)
Hello Makoto, should we uplift this fix to Aurora51? For Beta50, I am inclined to mark this wontfix unless we get a verification.
Flags: needinfo?(m_kato)
Hello Ritu, This issue was fixed as expected on a latest Nightly build. Thanks!
(Ubuntu 16.04, Nightly Build 20161017030209)
Flags: needinfo?(magicp.jp)
(In reply to Ritu Kothari (:ritu) from comment #16)
> Hello Makoto, should we uplift this fix to Aurora51? For Beta50, I am
> inclined to mark this wontfix unless we get a verification.

At it is UX issue for RTL users and risk is too low.  So we should uplift this as UX issue if possible,
Flags: needinfo?(m_kato)
Comment on attachment 8795641 [details]
Bug 1287278 - dropmaker-icon direction is wrong in RTL locale on Linux.

Approval Request Comment
[Feature/regressing bug #]:
Bug 1186003 (GTK3 support)

[User impact if declined]:
When user locale is RTL such as Arabic, up/down arrow of dropdown is drawn as left arrow.

[Describe test coverage new/current, TreeHerder]:
Landed in m-c.

[Risks and why]:
Low.  This is UX issue for RTL locale only.
 
[String/UUID change made/needed]:
No
Attachment #8795641 - Flags: approval-mozilla-aurora?
Comment on attachment 8795641 [details]
Bug 1287278 - dropmaker-icon direction is wrong in RTL locale on Linux.

Approval Request Comment
[Feature/regressing bug #]:
Bug 1186003 (GTK3 support)

[User impact if declined]:
When user locale is RTL such as Arabic, up/down arrow of dropdown is drawn as left arrow.

[Describe test coverage new/current, TreeHerder]:
Landed in m-c.

[Risks and why]:
Low.  This is UX issue for RTL locale only.
 
[String/UUID change made/needed]:
No
Attachment #8795641 - Flags: approval-mozilla-beta?
(In reply to magicp from comment #17)
> Created attachment 8801929 [details]
> Screenshot from 2016-10-18 08-38-24.png
> 
> Hello Ritu, This issue was fixed as expected on a latest Nightly build.
> Thanks!
> (Ubuntu 16.04, Nightly Build 20161017030209)

Thanks a lot for your awesome work! :)
Status: RESOLVED → VERIFIED
Comment on attachment 8795641 [details]
Bug 1287278 - dropmaker-icon direction is wrong in RTL locale on Linux.

Fix was verified on Nightly52, Aurora51+, Beta50+
Attachment #8795641 - Flags: approval-mozilla-beta?
Attachment #8795641 - Flags: approval-mozilla-beta+
Attachment #8795641 - Flags: approval-mozilla-aurora?
Attachment #8795641 - Flags: approval-mozilla-aurora+
QA Whiteboard: [good first verify]
I have reproduced this bug with Nightly 49.0a2 (2016-07-16) on Linux Mint 18, 64 bit!
The bug's fix is now verified on latest Nightly 53.0a1.

Nightly 53.0a1:

Build ID 	20161129030222
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0

[testday-20161127]
I have reproduced this bug on : Firefox 48.0.2 ar build under Ubuntu 14.04 64-bit.
I confirm that is fixed now using: Firefox 51.0b14 ar.
You need to log in before you can comment on or make changes to this bug.