Private Browsing Mode should delete bookmarks and list of closed tabs on quit

RESOLVED WORKSFORME

Status

()

Firefox
Private Browsing
--
enhancement
RESOLVED WORKSFORME
a year ago
a year ago

People

(Reporter: Nick Levinson, Unassigned)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
When private browsing mode is on, bookmarks and a list of closed tabs should not survive closing and reopening the whole browser instance, but they do. They effectively tell someone using the computer what prior user/s have been doing. To reproduce: 

1. Edit menu > Preferences > Privacy > History > Always Use Private Browsing Mode on (checkmarked).

2. Open new tabs, enter some websites that you probably haven't visited with this browser, visit each one, and close each tab except one (closing all tabs will close the browser prematurely).

3. Create some bookmarks (besides the default bookmarks that are shipped with Firefox). I do not know the difference between sorted and unsorted, but try to make a few of each.

4. Close & reopen the browser.

5. Bookmarks menu, to see a list of bookmarks.

6. History menu > Recently Closed Tabs, to see a list of closed tabs.

7. History menu > Show All History > Library dialog > All Bookmarks > Bookmarks Menu, to see a list of bookmarks.

8. History menu > Show All History > Library dialog > All Bookmarks > Unsorted Bookmarks, to see some more bookmarks.
We've previously decided that making a bookmark while in a private window (or using permanent private browsing mode) is an explicit action that we're not going to undo later. See bug 566010 for the previous discussion about that.

I'm surprised that Recently Closed Tabs contains data, however. I need to dig around to see whether that's intentional or not.
I can't reproduce the persistent Recently Closed Tabs problem using the steps described in comment 0. Nick, do you have specific steps you use that can reproduce the contents of Recently Closed Tabs showing up after closing the browser in particular?
Flags: needinfo?(Nick_Levinson)
(Reporter)

Comment 3

a year ago
I can't reproduce the history problem either, now, so I'm closing this. Maybe it's because we just got a full-version update to FF. The bookmarks aspect makes sense. Thank you.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(Nick_Levinson)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.