ALL browser-level keyboard shortcuts blocked on community.skype.com

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: from_bugzilla2, Unassigned)

Tracking

49 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.90 Safari/537.36
Build ID: 20160704175611

Steps to reproduce:

1. Visit https://community.skype.com/t5/Linux/Skype-for-Linux-Alpha-and-calling-on-Chrome-amp-Chromebooks/td-p/4434299/page/26
2. Attempt the Ctrl+L, Ctrl+F, Ctrl+A, Ctrl+C, Ctrl+Shift+T, and / (quick find) keyboard shortcuts
3. Tap Alt to call up the menu bar
4. Nothing will happen for any of those shortcuts
5. Try holding Shift and repeating the previous actions in case it works as with right-click
6. Nothing will happen
7. Switch tabs and try Ctrl+F again to make sure it's not a broken Firefox
8. It will work normally
9. Switch back and confirm it's still an issue.
10. Click "Reply" one one of the posts in the misbehaving tab and try Ctrl+F
11. It works normally, indicating it's not a bug causing the tab to be broken
12. Click the link in the breadcrumb trail to navigate the same tab back to the thread view
13. Keyboard shortcuts become non-responsive again, indicating that it's not a transient error fixed by any navigation


Actual results:

The site is able to block pretty much every predefined keyboard shortcut except those on a whitelist such as Ctrl+W and Ctrl+T... and, given the shortcuts in question, I suspect the whitelist is implemented on skype.com, not in Firefox.


Expected results:

I'm not entirely sure what would be the best option to balance the needs of normal websites and in-browser apps, but a badly written website should not have that much power to ruin a user's browsing experience.

As-is, this feels like the kind of broken functionality which led to Firefox implementing Shift+RightClick and Chrome inventing the "prevent future popups" checkbox for alert() and friends.

Comment 1

2 years ago
User Agent 	Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID 	20160720030208

I tried to reproduce the issue but it works fine for me on latest Nightly (Windows 7). Ctrl+L, Ctrl+F, Ctrl+A, Ctrl+C, Ctrl+Shift+T, / (quick find) and ALT keyboard shortcuts work fine on https://community.skype.com/t5/Linux/Skype-for-Linux-Alpha-and-calling-on-Chrome-amp-Chromebooks/td-p/4434299/page/26 page .

Can you still reproduce the issue even in Safe Mode or with a new profile?
Flags: needinfo?(from_bugzilla2)
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64

Comment 2

2 years ago
Closing as incomplete due to lack of response. 
Stephan if you can reproduce the issue on a current Firefox build, with a new profile and/or with Safe Mode, please reopen the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 3

2 years ago
Sorry about that. My open tabs exploded over the last week and this got pushed out of the visible set.

I've moved it to the front of the queue and I should have an answer for you within the next 48 hours.
(Reporter)

Comment 4

2 years ago
I just checked and it appears that Microsoft fixed it on their end since it now works not only in a fresh profile but in the same profile where I was experiencing the problem before.
Resolution: INCOMPLETE → WORKSFORME
(Reporter)

Comment 5

2 years ago
Whoops. Forgot to clear the needinfo.
Flags: needinfo?(from_bugzilla2)

Comment 6

2 years ago
Great. Thanks Stephan.
You need to log in before you can comment on or make changes to this bug.