Courier IMAP: Download of message fails when the body contains escape characters

RESOLVED WORKSFORME

Status

MailNews Core
Networking: IMAP
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: martin, Assigned: Scott MacGregor)

Tracking

({imap-interop})

Trunk
x86
Windows 2000
imap-interop

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
IMAP download of a message body will FAIL if the msg contains escape chars. Msg
headers are downloaded properly, but downloadfing the body itself stalls. 

The error is triggered on msg download, either by trying to read the msg or by
running a "sync folders" command. 

Netscape 4.78 will download and display the msg.

Mozilla 0.9.8 on Win2k
Server: CourierIMAP 1.3.11 compiled with the "--with-client-bug-workarounds"
SSL: OpenSSL 0.9.6b

The msg looks like:
Subject: 
        Cron <htdocs@kick> cd ~/htdocs/docs/howto/ ; lwp-download
       
http://www.ibiblio.org/pub/Linux/docs/HOWTO/other-formats/html/Linux-html-HOWTOs.tar.gz
        ; tar -xzf Linux-html-HOWTOs.tar.gz
   Date: 
        2 Mar 2002 11:00:02 -0000
   From: 
        root@kick.cwa.co.nz (Cron Daemon)
     To: 
        htdocs@kick.cwa.co.nz




/bin/sh: cd: /home/htdocs/htdocs/docs/howto/: No such file or directory
Saving to 'Linux-html-HOWTOs.tar.gz'...

0% of 8.96 MB
-
0% of 8.96 MB
\
0% of 8.96 MB
|
0% of 8.96 MB (at 22.7 KB/sec, 6 minutes remaining)
/
1% of 8.96 MB (at 26.7 KB/sec, 5 minutes remaining)
-
1% of 8.96 MB (at 27.7 KB/sec, 5 minutes remaining)
\
2% of 8.96 MB (at 27.9 KB/sec, 5 minutes remaining)
|
2% of 8.96 MB (at 28.3 KB/sec, 5 minutes remaining)
/
2% of 8.96 MB (at 29.4 KB/sec, 5 minutes remaining)
-

(...) 


8.96 MB received in 5 minutes (27.2 KB/sec)
(Reporter)

Comment 1

17 years ago
Created attachment 72324 [details]
Email that triggers the problem  -- as stored in the server -- .
(Reporter)

Comment 2

17 years ago
Should you need a test account -- even with an email in it with the problem --
I'll be happy to set that up. 



m

Comment 4

16 years ago
No reply.  Resolving.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Updated

16 years ago
Keywords: interop
QA Contact: huang → meehansqa
Summary: Download of message fails when the body contains escape characters → Courier IMAP: Download of message fails when the body contains escape characters
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.