Edit and resend will incorrectly resend modified querystring params

RESOLVED WORKSFORME

Status

P2
normal
RESOLVED WORKSFORME
2 years ago
2 months ago

People

(Reporter: greg, Unassigned)

Tracking

(Blocks: 1 bug)

47 Branch

Firefox Tracking Flags

(firefox50 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8771995 [details]
firefox_querystring_edit_and_send.png

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160711192800

Steps to reproduce:

- With your debug tools open, and network selected
- Goto a URL with a simple querystring, eg
https://www.google.com/textinputassistant/tia.png?hello=world
- Now click on the edit and resend
- In the panel that has the querystring, delete upto but no including the equals
(so you have "hello=")
- Now type a replacement value
- Send the result


Actual results:

- The querystring is incorrect sent.
- Upon deleting upto the =, it will put the querystring at the start of the url, followed by the first character of the value you enter, then the rest of the url, then ?
- Example, if in the above I replace hello=world with hello=blah and resent the request, it would be
hello=bhttps://www.google.com/textinputassistant/tia.png?


Expected results:

- Should correctly send the new querystring so I can make repeat requests
(Reporter)

Updated

2 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Comment 1

2 years ago
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID 	20160720030208

Reproduced on latest Nightly (50.0a1) on Ubuntu 15.04 and Windows 7.
Status: UNCONFIRMED → NEW
status-firefox50: --- → affected
Component: Untriaged → Developer Tools: Netmonitor
Ever confirmed: true
OS: Linux → All
Hardware: x86_64 → All
Thanks for the report. I can see the problem on my machine too.

Honza
Priority: -- → P2

Comment 3

2 years ago
Also, encoded in UTF-8 parameters (e. g. russian chars) will be **** up.

Updated

6 months ago
Product: Firefox → DevTools

Comment 4

2 months ago
I think this bug with changing the query params is resolved. I wasn't able to reproduce it on OSX or archlinux.
Thanks for the update. Works for me, closing.

Honza
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

2 months ago
Verified working for me too.

62.0.3 (64bit), Fedora 28.

Thanks all
Greg
You need to log in before you can comment on or make changes to this bug.