Remove test_bug651100.js

RESOLVED FIXED in Firefox 50

Status

()

Core
Networking: Cache
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: mayhemer, Assigned: mayhemer)

Tracking

unspecified
mozilla50
Points:
---

Firefox Tracking Flags

(firefox50 fixed)

Details

(Whiteboard: [cache2][necko-active])

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
It's pretty much code specific to the old cache back end and cannot be easily converted (with preserving the intended check - if there is actually anything to check) for the new back end.
(Assignee)

Comment 1

2 years ago
Created attachment 8772016 [details] [diff] [review]
v1

The test is anyway disabled.  It's trying to check we don't trigger some weird blocking IO operations when we reach certain limits on a single entry (65MB).  This all was intended and fixed in the old cache.  Cache2 doesn't suffer from this bug.  The test e.g. fails when trying to add metadata of 1mb (we have a hard limit of just 64kb per element).  Hence, to make this bug work it would mean to actually break what it tests.  -> no longer relevant for me.
Assignee: nobody → honzab.moz
Status: NEW → ASSIGNED
Attachment #8772016 - Flags: review?(michal.novotny)
(Assignee)

Updated

2 years ago
Whiteboard: [cache2][necko-backlog] → [cache2][necko-active]
Attachment #8772016 - Flags: review?(michal.novotny) → review+
(Assignee)

Updated

2 years ago
Attachment #8772016 - Attachment is patch: true
(Assignee)

Comment 2

2 years ago
The test was disabled anyway.
Keywords: checkin-needed

Comment 3

2 years ago
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e5d39287514f
remove no longer relevant test_bug651100.js, r=jduell
Keywords: checkin-needed

Comment 4

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/e5d39287514f
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox50: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
You need to log in before you can comment on or make changes to this bug.