browser_webRequest 'dead CPOW' intermittent failure on Win7 VM

RESOLVED DUPLICATE of bug 1166013

Status

Testing
Mochitest
RESOLVED DUPLICATE of bug 1166013
a year ago
a year ago

People

(Reporter: rwood, Unassigned)

Tracking

49 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

MozReview Requests

Submitter Diff Changes Open Issues Last Updated
Loading...
Error loading review requests:

Attachments

(1 attachment)

(Reporter)

Description

a year ago
On Win7 VM debug e10s, toolkit/modules/tests/browser/browser_WebRequest.js intermittently fails with a 'dead CPOW'.

https://treeherder.mozilla.org/logviewer.html#?job_id=23831402&repo=try

INFO -  469 INFO onBeforeSendHeaders http://example.com/browser/toolkit/modules/tests/browser/nonexistent_script_url.js
15:10:50     INFO -  470 INFO TEST-PASS | toolkit/modules/tests/browser/browser_WebRequest.js | correct <browser> element -
INFO -  471 INFO TEST-PASS | toolkit/modules/tests/browser/browser_WebRequest.js | resource type is correct -
INFO -  472 INFO TEST-PASS | toolkit/modules/tests/browser/browser_WebRequest.js | window ID same in onBeforeSendHeaders as onBeforeRequest -
INFO -  473 INFO TEST-UNEXPECTED-FAIL | toolkit/modules/tests/browser/browser_WebRequest.js | Uncaught exception - at :0 - Error: operation not possible on dead CPOW
INFO -  Stack trace:
INFO -      Tester_execTest@chrome://mochikit/content/browser-test.js:791:9
INFO -      Tester.prototype.nextTest</<@chrome://mochikit/content/browser-test.js:711:7
(Reporter)

Comment 1

a year ago
Created attachment 8772115 [details]
Bug 1287539 - disable browser_webRequest intermittent for win7vm;

Review commit: https://reviewboard.mozilla.org/r/65008/diff/#index_header
See other reviews: https://reviewboard.mozilla.org/r/65008/
Attachment #8772115 - Flags: review?(jmaher)
if you look at bug 1166013, there is an intermittent for this test/error.  It shows up on win7 primarily, 15 times in the last week (out of 200 pushes for inbound).  I am not 100% sure this ran on every push, but lets assume 300 times this test ran (on all branches), and we failed 1 out of 20 times.  The question is, do we have <=2 issues with this test on try for win7-vm?  if so, it is failing at the same rate as on inbound.

Possibly we can do more retriggers (up to 100) to know the rate and see if we have <5 on win7-vm.
Attachment #8772115 - Flags: review?(jmaher)
(Reporter)

Comment 3

a year ago
Windows 7 VM debug e10s, 100x on try:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=05e46d1cf8fb&filter-searchStr=bc4

The test (browser_WebRequest) failed with 'dead CPOW' 3 times out of 100 runs. So this is not any worse than the intermittent rate on inbound. Closing this as duplicate of bug 1166013.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1166013
You need to log in before you can comment on or make changes to this bug.