Email for watched page contains incorrect 'from' revision in "Compare" link

RESOLVED DUPLICATE of bug 1239141

Status

Mozilla Developer Network
Wiki pages
RESOLVED DUPLICATE of bug 1239141
a year ago
a year ago

People

(Reporter: gerald, Unassigned)

Tracking

Details

(Whiteboard: [specification][type:bug])

(Reporter)

Description

a year ago
What did you do?
================
1. Watch a page
2. Get someone to modify the page
3. Check email

What happened?
==============
Received an email with the following "Compare on MDN:" link:
https://developer.mozilla.org/en-US/docs/Using_CXX_in_Mozilla_code$compare?to=1085647&from=1085647&utm_campaign=Wiki+Doc+Edits&utm_medium=email&utm_source=developer.mozilla.org

Notice that the 'to' and 'from' are the same, so going there shows no changes!

What should have happened?
==========================
It should have shown the correct 'from' revision number, in this case 1080882.

By going through the page's history UI, I got the following (correct) link:
https://developer.mozilla.org/en-US/docs/Using_CXX_in_Mozilla_code$compare?locale=en-US&to=1085647&from=1080882

Is there anything else we should know?
======================================
No sure if it's related, but from the email link (the one showing no differences), if I click on "Change Revisions" and then "COMPARE SELECTED REVISIONS", it brings me to the page editor!
(Reporter)

Comment 1

a year ago
To make things more "interesting", this is an intermittent problem.

I've just received another email for the same page, and this time the link was correct. In this case:
https://developer.mozilla.org/en-US/docs/Using_CXX_in_Mozilla_code$compare?to=1086391&from=1085647&utm_campaign=Wiki+Doc+Edits&utm_medium=email&utm_source=developer.mozilla.org

Good luck!
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1239141
You need to log in before you can comment on or make changes to this bug.