Too many active decoders on Facebook

RESOLVED DUPLICATE of bug 1293937

Status

()

defect
P3
normal
RESOLVED DUPLICATE of bug 1293937
3 years ago
3 years ago

People

(Reporter: ajones, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [platform-rel-Facebook])

Steps to reproduce:

* Install aboutmedia addon
* Scroll through Facebook past a number of videos
* Look at the video elements in F10 -> Tools -> Page Info on the Media tab
* Look at the video elements in about:media

Expected results:

Only the videos in Page Info should be running. Others should be shut down.

Actual results:

Most of the videos in about:media have active decoders even though they don't appear in the page info.

Note: I'm not sure why these videos aren't shut down by the dormant mode timer.
about:media shows the media element on a page; are you sure the decoder aren't shutdown ?
this is what's showing on about:media after leaving the facebook page idle for 1 minute:

	https://video-syd1-1.xx.fbcdn.net/v/t42.1790-2/12689932_642426669238780_949368584_n.mp4?efg=eyJybHIiOjQ2OCwicmxhIjo2MjYsInZlbmNvZGVfdGFnIjoidjNfNDI2X2NyZl8yM19tYWluXzMuMF9zZCJ9&rl=468&vabr=260&oh=02b94e0673178e3680979c38fa7c3b47&oe=578DD891
	currentTime: 0
	Quality: 100% (total:12 dropped:0 corrupted:0)
	Buffered ranges: [(0, 19.111429)]
	Internal Data:
	audio decoder: shutdown
	audio frames decoded: 1
	audio state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 decoder:0 tt:-1.000000 tths:-1 in:0 out:0 qs=0 pending:0 waiting:0 sid:4294967295
	video decoder: shutdown
	hardware video decoding: disabled
	video frames decoded: 1 (skipped:0)
	video state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 decoder:0 tt:-1.000000 tths:-1 in:0 out:0 qs=0 pending:0 waiting:0 sid:4294967295


note the: "video decoder: shutdown"

this indicates that there are none running at present. it will be recreated the next time we need a frame decoded
Priority: -- → P3
platform-rel: --- → ?
Whiteboard: [platform-rel-Facebook]
No longer blocks: 1276556
Depends on: 1276556
platform-rel: ? → -
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1293937
No longer blocks: 1254389
platform-rel: - → ---
No longer depends on: 1276556
You need to log in before you can comment on or make changes to this bug.