Closed Bug 1287676 Opened 6 years ago Closed 2 years ago

Crash in java.lang.NullPointerException: at org.mozilla.gecko.gfx.GeckoLayerClient$1.run(GeckoLayerClient.java)

Categories

(Firefox for Android Graveyard :: Toolbar, defect, P2)

Unspecified
Android
defect

Tracking

(firefox47 wontfix, firefox48 wontfix, firefox49 wontfix, firefox50 fix-optional, firefox51 ?)

RESOLVED WORKSFORME
Tracking Status
firefox47 --- wontfix
firefox48 --- wontfix
firefox49 --- wontfix
firefox50 --- fix-optional
firefox51 --- ?

People

(Reporter: ting, Unassigned)

References

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-5867b47e-2683-45c4-96fc-f74c22160718.
=============================================================

#10 with 0719 Nightly on Android, however there're 4786 crash reports since 0701, over 200 per day.

https://crash-stats.mozilla.com/signature/?product=FennecAndroid&date=%3E%3D2016-01-01&signature=java.lang.NullPointerException%3A%20at%20org.mozilla.gecko.gfx.GeckoLayerClient%241.run%28GeckoLayerClient.java%29#graphs
:kats, any ideas?
Flags: needinfo?(bugmail)
Seems like it's not a recent regression, it's pretty high volume in 47 release as well. The crash stack points to http://searchfox.org/mozilla-central/rev/65bed54efcce67cf04a890f7fe253ccdfa6befdc/mobile/android/base/java/org/mozilla/gecko/gfx/GeckoLayerClient.java#176 - Dylan, any ideas?
Flags: needinfo?(bugmail) → needinfo?(droeh)
I'm not sure why this would suddenly have become a problem; the crashes start before any of the major changes I've made to GLController and friends. However, a first attempt at a fix here may be as simple as failing gracefully if mView or mView.getGLController() are null.
Flags: needinfo?(droeh)
The most recent crash report for this points to this line specifically:

https://hg.mozilla.org/mozilla-central/file/711963e8daa312ae06409f8ab5c06612cb0b8f7b/mobile/android/base/java/org/mozilla/gecko/gfx/GeckoLayerClient.java#l176

which was modified by bug 1288467 since then. So it may be fixed already. I don't think we want to uplift bug 1288467 to 49, although we might want to put in a nullguard directly into 49 beta. On the other hand, just adding a nullguard might paper over the crash and leave the browser in an unusable state, so I'm not really sure it's worth doing.
I don't see any crashes with this signature in 49 (since July 1). There's a grand total of three crashes on 50, all of which occurred in the latter half of July. Nothing on 51 yet.

Closing because no crashes reported for 12 weeks.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.