bidi charsets support in chatzilla

RESOLVED WORKSFORME

Status

Other Applications
ChatZilla
--
major
RESOLVED WORKSFORME
17 years ago
14 years ago

People

(Reporter: m_vitaly, Assigned: Robert Ginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ru-RU; rv:0.9.8) Gecko/20020205
BuildID:    2002020511

Chatzilla should support bi-directional languages such as Hebrew, Arabic , etc.

Reproducible: Always
Steps to Reproduce:
Open chatzilla and try to go to a channel with people who speak Hebrew or Arabic.

Actual Results:  You will see the sentences reversed (backwards).
(Reporter)

Comment 1

17 years ago
depends on 41564
Depends on: 41564

Comment 2

17 years ago
I am confirming this bug for now. Shoshanna, can you re-confirm the
problem? 
You can set the charset in Chatzilla using the following command:

/charset ISO-8859-8-I
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

17 years ago
irc is blocked by the network here, so I can't test :-(

Comment 4

17 years ago
m_vitaly, which encoding of Hebrew do you use by

/charset "charset_name" command ?

Also which encoding do you think other people are using in
the chat channels?
(Reporter)

Comment 5

17 years ago
I've tried:
/charset ISO-8859-8
/charset ISO-8859-8-I
/charset Windows-1255

All of them show hebrew characters.

I'm not sure but I think the third one (Windows-1255) is used by other irc users
(especially Windows users).
The problem is that this charset has an reversed tag or something like that,
which chatzilla ignores.

The first two charsets should show exactly what chatzilla gets from the server,
while the third one should reverse the order of charactters and words in each
message.
(Reporter)

Comment 6

17 years ago
works for me at 2002031115 (0.9.9)
:)

anybody else ?
Please check arabian and other right-sided lang.

I can't get the first chatsets (not the dominating ones)
it doesn't seem to be a problem but chatzilla should support all charsets - as
for now the old charsets that shouldn't be converted are converted...
:(
Works for me in Windows and Linux in ISO-8859-8-i, windows-1255 (both Hebrew)
and windows-1256 (Arabic), modulo bug 95400 in the text input field. ISO-8859-8
(Visual Hebrew) displays the same as ISO-8859-8-i (Logical Hebrew), but I am
fine with that -- there is no reason to extend the backward compatibility
support for Visual Hebrew HTML into IRC.

Marking WORKSFORME. Please feel free to reopen if anyone is still seeing
reversed text. It would probably be helpful to specify the channel and network.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.