Firefox webrtc ICE: peer-reflexive candidate was selected and ice state succeed but cannot work

RESOLVED INVALID

Status

()

Core
WebRTC: Networking
RESOLVED INVALID
2 years ago
a year ago

People

(Reporter: zhuwjsnake, Unassigned)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8772370 [details]
aboutWebrtc.html

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.112 Safari/537.36

Steps to reproduce:

I built a MCU on a server with a public ip.
Firefox 47.0.1(on Windows 7/10) was behind a symmetric NAT.
1. open https://61.153.48.134:3004 in Firefox
2. click the button in the webpage. And then allow firefox to share your camera and microphone in the pop-up window. This behavior will publish your video and audio to MCU. (the published video and audio will not be recorded or collected. Feel free to access.)

Peer reflexive candidate works well in Chrome but cannot work in Firefox.


Actual results:

When Firefox connected to MCU, a peer-reflexive candidate ip/port was successfully discovered and selected during ICE negotiation by STUN request/response. Audio/Video RTP channels were also created successfully. But no outbound data was transmitted.


Expected results:

Because peer reflexive candidate works well in Chrome, you can follow the reproduce steps in Chrome to see: your own camera content is at left side and the published A/V data returned from MCU is at right side.

Since this issue can be reproduced easily, therefore I will not attach pcap file. If they are required, please feel free to let me know.

Updated

2 years ago
Component: Untriaged → WebRTC: Networking
Product: Firefox → Core
(Reporter)

Comment 1

2 years ago
After looking into this issue, I suspect it was caused by ICE problem at MCU side.
Therefore i will close this case temporarily.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.