Inconsistency when the attendee accepts an event with caldav and local calendars

RESOLVED WORKSFORME

Status

Calendar
E-mail based Scheduling (iTIP/iMIP)
RESOLVED WORKSFORME
2 years ago
a year ago

People

(Reporter: ldubois, Unassigned)

Tracking

Lightning 4.7

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:38.0) Gecko/20100101 Firefox/38.0 Iceweasel/38.8.0
Build ID: 20160426225641

Steps to reproduce:

UserA has two calendars:
- A caldav calendar
- A local calendar with the same email addresses associated than the caldav

* UserB invites userA to an event. UserA doesn't synchronize
* In the email notification, userA accepts the event (with the blue bar)
* A popup is displayed and lightning ask userA to select a calendar: the caldav or the local
* UserA selects the local


Actual results:

This event is added to the local calendar.
When userA synchronizes, this event is also displayed in the caldav calendar, so userA gets it twice.


Expected results:

It can be more consistent:
- Either when userA selects the local calendar, the event is added to the local calendar only 
- Or at this moment, Lightning don't ask the user to select a calendar and forces the participation change in the caldav calendar.

This issue seems a bit similar with the 1059592
When the user selects the local calendar, then the event is added there. If the event also appears in the caldav calendar and it is just not there because the user has not synchronized, then the event is added server-side and there is nothing that can be done in Lightning.

I think we have at least one bug open to do something sensible when displaying invitation regarding synchronization, although I can't find it now. I'm inclined to close this issue in favor of that bug I have in mind, and the fact that by the current design the behavoir is expected. Thank you for reporting though, generally this is an issue we need to solve in some way.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.