Closed Bug 1288021 Opened 7 years ago Closed 6 years ago

GMPs on a Network path not mapped to drive letter fail to load.

Categories

(Core :: Audio/Video: GMP, defect)

All
Windows
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla50
Tracking Status
firefox49 --- fixed
firefox50 --- fixed

People

(Reporter: bobowen, Assigned: bobowen)

Details

Attachments

(1 file)

We changed the chromium sandbox to allow rules for network drives, but if the network path is not mapped to a drive letter, then it needs to be in a specific format for the sandbox rule.
Attachment #8772733 - Flags: review?(cpearce) → review+
Comment on attachment 8772733 [details]
Bug 1288021: When we have a network GMP path fix the format for the sandbox rule.

https://reviewboard.mozilla.org/r/65496/#review62672
Pushed by bobowencode@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/70a207408632
When we have a network GMP path fix the format for the sandbox rule. r=cpearce
https://hg.mozilla.org/mozilla-central/rev/70a207408632
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
Comment on attachment 8772733 [details]
Bug 1288021: When we have a network GMP path fix the format for the sandbox rule.

Approval Request Comment
[Feature/regressing bug #]:
This problem would have been there since first launch of sandboxed GMP.

[User impact if declined]:
Users won't be able to load GMPs that exist on a non-mapped network path (usually because their profile directory is).

[Describe test coverage new/current, TreeHerder]:
GMP in general has coverage in TreeHerder.
Problem with network path manually reproduced with clearkey GMP and fix tested.

[Risks and why]: 
Low - simple change to the path, which is only applied after specific tests for a non-mapped network path.

[String/UUID change made/needed]:
None
Attachment #8772733 - Flags: approval-mozilla-beta?
Comment on attachment 8772733 [details]
Bug 1288021: When we have a network GMP path fix the format for the sandbox rule.

This patch fixes the format for the sandbox rule. Take it in 49 beta.
Attachment #8772733 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.