Interdiff failing with "No valid patch files were found in the attachment"

RESOLVED WORKSFORME

Status

()

bugzilla.mozilla.org
User Interface
P1
critical
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: u462496, Assigned: dylan)

Tracking

Production

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
This started happening a few weeks ago (for me) and now is consistently happening, I keep getting this error on anything I've tried.  Haven't seen any activity on related bugs since 2013 so I am filing a new one.

The last two patches compared are nearly identical:

https://bugzilla.mozilla.org/attachment.cgi?oldid=8771989&action=interdiff&newid=8772845&headers=1
(Assignee)

Updated

2 years ago
Assignee: nobody → dylan
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P1
(Reporter)

Comment 1

2 years ago
This is a sorely missed feature.  Is anything happening with this? :-)
(Assignee)

Comment 2

2 years ago
It appears the problem is the patches in question don't have enough context to for interdiff to figure out what happened.
The feature itself hasn't changed, but something about diff files has. :-/
(Reporter)

Comment 3

2 years ago
They are the standard default 8 line context (when using `hg diff`) which has worked fine for a long time before.  I continue to use this context on all my patches but interdiff still is not working.

Can you give me an example of patches this is working on?
(Assignee)

Comment 6

2 years ago
While it is true that some "hg diff" patches don't work with interdiff, this is not something BMO can fix. It may be possible to configure hg in such a way that the diff output works, but a better long-term solution is probably in using mozreview.

Nothing has changed about how interdiff works in quite a long time, and traditional diff(1) based patches (as demonstrated on this bug) still work. 

I'm sorry, but there's nothing I can do. :(
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.