Crash in mozilla::MediaDecoderStateMachine::GetDecodedAudioDuration

RESOLVED INVALID

Status

()

Core
Audio/Video: Playback
--
critical
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: padenot, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

2 years ago
This bug was filed from the Socorro interface and is 
report bp-67a53e0a-fe10-46ed-bbd3-251262160720.
=============================================================

I can repro this on my macbook pro when scrolling twitter.
https://hg.mozilla.org/integration/mozilla-inbound/annotate/aac8ff1024c5/dom/media/MediaDecoderStateMachine.cpp#l445

It looks like mMediaSink is null. But MDSM never sets it to null.

How reproducible is the crash?
(Reporter)

Comment 2

2 years ago
Three times in a couple minutes, I'd say it's pretty reproducible.
Can't repro it on my Mac. Which twitter page were you browsing?
stack frame:
 "rax": "0x0000000000000000",

It looks like the pointer to the virtual table is null. This is either a UAF or memory corruption.
(Reporter)

Comment 5

2 years ago
Any twitter page that has video in tweets reproduces for me.
Paul - can you give a specific example please?

Jean-Yves - can you repro this issue?
Flags: needinfo?(padenot)
Flags: needinfo?(jyavenard)
(Reporter)

Comment 7

2 years ago
I can't really, I'm just scrolling my timeline (twitter.com) when logged in, it crashes often. Maybe scrolling a twitter page where there are a lot of videos will help. For example, https://twitter.com/franceinfo.
Flags: needinfo?(padenot)
Hi Paul,
Since you are able to repro this issue, can you attach a debugger and confirm if comment 4 is true?
(Reporter)

Comment 9

2 years ago
I can't repro anymore, sorry. I'll reopen if I have more info or if I can repro.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
Flags: needinfo?(jyavenard)
You need to log in before you can comment on or make changes to this bug.