Closed Bug 128812 Opened 21 years ago Closed 9 years ago

[RFE] Calendar tray icon (ie. quicklaunch)

Categories

(Calendar :: Sunbird Only, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: xyzzy, Unassigned)

References

Details

I've used this feature in other calendar apps, and IMHO, it would be a very
useful to have a tray icon in the taskbar for quick access to events, todo, and
anything else that makes sense.

Generalization work for tray icons is in progress in bug 115348.
Depends on: 115348
*** Bug 130906 has been marked as a duplicate of this bug. ***
Adding on quicklaunch to title to remind me that its only for windows quick launch.
Summary: [RFE] Calendar tray icon → [RFE] Calendar tray icon (ie. quicklaunch)
If someone wants to take this on, go for it. Just assign the bug to yourself.
Assignee: mikep → nobody
*** Bug 173890 has been marked as a duplicate of this bug. ***
I guess, main function for Calendar Quick Launch should be not "Fast launch by
click" but reminder for coming events.

Maybe, we even wouldn't need for separate Calendar icon in system tray, main
Mozilla Quick Launch icon with added reminder (and, might be, some another
Calendar functions) is enough.
In Windows, create a shortcut and add "-calendar" after the path to launch
mozilla, for example:
"C:\Program Files\mozilla.org\Mozilla\mozilla.exe" -calendar
I tried the path mentioned below and it didn't work.  When I launched the icon,
the Mozilla browser opened up.  I tried on both a W2K and XP machine.
In windows don't use "-calender" to launch Mozilla, but instead use "-webcal" to
launch Mozilla.
The shortcut on my pc:
"C:\Program Files\mozilla.org\Mozilla\mozilla.exe" -webcal

I'm using win2k with Mozilla 1.5.
I've got this information from components/calendarService.js.
Why not make Quick Launch configurable so that any add-ons one chooses can be
added to it?
I've created Bug # 235999 which connects this issue with adding 
additional features such as composing new mail (Bug # 189866 ).
*** Bug 263435 has been marked as a duplicate of this bug. ***
*** Bug 266061 has been marked as a duplicate of this bug. ***
*** Bug 267493 has been marked as a duplicate of this bug. ***
*** Bug 274952 has been marked as a duplicate of this bug. ***
*** Bug 242903 has been marked as a duplicate of this bug. ***
*** Bug 278399 has been marked as a duplicate of this bug. ***
A minimize to tray feature would also be very handy, as you can then keep it out
of the way.
*** Bug 281954 has been marked as a duplicate of this bug. ***
(In reply to comment #18)
> A minimize to tray feature would also be very handy, as you can then keep it out
> of the way.

Especially important for the reminder funktion, since the reminder works only
with sunbird being opened. An always opened window disturbs the working performance.
*** Bug 268412 has been marked as a duplicate of this bug. ***
*** Bug 306418 has been marked as a duplicate of this bug. ***
Gnome Clock provides integration with Evolution Calaendar. It would be nice to
see this extended to cover Sunbird
The Thunderbird and Firefox Extension minimize to system tray should work for
calendar as wells seeing as it is an extension to these progams, however I think
it's less of an extension and more of a standalone program started through
either of the above which is why it doesn't minimize right. It would be great if
I could add that extension to Sunbird/Calendar.
The MinimizeToTray extension works with Calendar and the new Sunbird builds. 
There's just a small bug where we're currently not yet passing it a tray menu to
load.  So for now, all you get is a tray icon and the ability to restore the
window from the tray icon.  
QA Contact: colint → sunbird
*** Bug 330690 has been marked as a duplicate of this bug. ***
*** Bug 349402 has been marked as a duplicate of this bug. ***
  "quicklaunch" is IMO the thing in Windows on the bottom left next to the [Start] (or whatever you write on it) button.
  We are talking about systray here, right? quicklaunch is implemented already. 
  What menu options should be in there? Actually, just restoring would be enough for me, New Task/Event would be overkill, View Selection inappropriate. 
      +-----------+
      | *Restore* |
      +-----------+
      | About ...  |
      | Help ...   |
      +-----------+
  Speaking of GNOME, Comment #23, It would be cool to reuse the lefthandcalendar to open on singleclick. 
  I often double click on the Windows date (change time and date), just to see which day is the 20th of the next month. 
  It would be beautiful if lefthandcalendar pops up like in GNOME on single click on the icon, clicking on a date shows the app, as well as double clicking on the icon.
     
  I guess it is quite possible to reuse the MinimizeToTray extension here, although I'd like to see this in the app (as it is also partly solving the alarm dilemma, Bug 134969).
Depends on: 325353
Status report for Sunbird 0.3.1 [Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9a1) Gecko/20070213 Sunbird/0.3.1] German version on WinXP

With MinimizeToTray(0.0.1....15+) extension:
It is still not working to start Sunbird in minimized mode at startup or by hand.

With SunTray.exe 0.9:
SunTray is ignoring the -start or -Start or - Start option to start Sunbird minimized. Sunbird opens fullscreen.
Duplicate of this bug: 376783
Probably this bug depends on Bug 378557
There is now a patch available for Bug 378557
I agree, I wish there were a system tray icon and the hability to run Sunbird in the background at system startup.
Resolving as WONTFIX because Sunbird has been discontinued and the code has been removed from the project.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.