Broken link for VIEW LIVE EXAMPLES

RESOLVED FIXED

Status

developer.mozilla.org
General
P5
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: robin.pham, Unassigned)

Tracking

(Blocks: 1 bug, {in-triage})

Details

(URL)

(Reporter)

Description

2 years ago
:: Developer Documentation Request

      Request Type: Correction
     Gecko Version: unspecified
 Technical Contact: 

:: Details

VIEW LIVE EXAMPLES button doesn't work, it tries to go to https://developer.mozilla.org/samples/cssref/border.html but that doesn't exist
This is working for me, can you retest and reopen the bug if not working?

Also do you get a 404 or another error?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

2 years ago
I get a 404.

Today I'm getting inconsistent results, sometimes 404, sometimes it loads, and sometimes it loads with different styles.

http://i.imgur.com/HYshCK6.jpg
http://i.imgur.com/PdR0UnR.jpg
http://i.imgur.com/Roswtd2.jpg
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Moving this to the devs.
Component: CSS → General
Product: Developer Documentation → Mozilla Developer Network
The page is https://developer.mozilla.org/samples/cssref/border.html, which is one I don't recognize.  The text "MDC Documentation" suggests this is an old page as well.  What is the page that contains the link "VIEW LIVE SAMPLES"?  It's not https://developer.mozilla.org/en-US/docs/Web/CSS/border.
Flags: needinfo?(robin.pham)
I found one: https://developer.mozilla.org/en-US/docs/Web/CSS/border-bottom

This is new functionality to me, and I suspect it is old code that should be migrated to the new embedded samples, like on:

https://developer.mozilla.org/en-US/docs/Web/CSS/border#Examples
Flags: needinfo?(robin.pham)
Yes, this is old functionality that we plan to remove this year.  The sample on border-bottom (and probably on all the border-* pages) should be migrated to a live code sample, like on https://developer.mozilla.org/en-US/docs/Web/CSS/border
Blocks: 1076893
Depends on: 1290455
Sorry for the bug spam, I haven't had my coffee yet.

We recently doubled the web servers on MDN, and these legacy sample files were not included in the new server.  This means you have a roughly 50% chance of any of the files not loading. I've opened bug 1290455 to fix this issue.

Thank you for discovering this, and filing the bug to shine some light into a dark corner of MDN.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: in-triage
With bug 1290455 fixed, the samples should now load consistently (no 404s), although they are still broken in many browsers (for example, this example loads base.css and wiki.css over HTTP, which is not allowed).
Status: NEW → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.