Test dependencies not installed when running |mach test /path/to/single/test.js|

RESOLVED DUPLICATE of bug 1286016

Status

RESOLVED DUPLICATE of bug 1286016
2 years ago
2 years ago

People

(Reporter: erahm, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

I'm trying to run a single test after performing a |mach build|, but the test is failing because it's missing definitions from it's head.js file.

STR:
1) |mach clobber|
2) |mach build|
3) |mach test toolkit/mozapps/extensions/test/browser/browser_cancelCompatCheck.js|

This produces various failures such as:

> Uncaught exception - at chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_cancelCompatCheck.js:238 - ReferenceError: PREF_STRICT_COMPAT is not defined

PREF_STRICT_COMPAT is defined in a head.js file [1] and is not installed under the testing directory:

> [erahm@mozilla21268 mozilla-central]$ ll obj-x86_64-pc-linux-gnu-clang-release/_tests/testing/mochitest/browser/toolkit/mozapps/extensions/test/browser/
> total 12
> drwxrwxr-x 2 erahm erahm 4096 Jul 20 10:59 ./
> drwxrwxr-x 3 erahm erahm 4096 Jul 20 10:59 ../
> lrwxrwxrwx 1 erahm erahm  100 Jul 20 10:59 browser_cancelCompatCheck.js -> /home/erahm/dev/mozilla-central/toolkit/mozapps/extensions/test/browser/browser_cancelCompatCheck.js

If I run |mach test toolkit/mozapps/extensions/test/browser/| instead things work (but it runs a ton of tests I don't care about).

[1] https://dxr.mozilla.org/mozilla-central/rev/4c05938a64a7fde3ac2d7f4493aee1c5f2ad8a0a/toolkit/mozapps/extensions/test/browser/head.js#45
I'm fairly sure this is a dupe of bug 1286016, I'll post a patch there.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1286016
You need to log in before you can comment on or make changes to this bug.