There is no tooltip displayed for the touch event button from RDM

VERIFIED FIXED in Firefox 50

Status

defect
P1
normal
VERIFIED FIXED
3 years ago
Last year

People

(Reporter: mboldan, Assigned: bigben)

Tracking

50 Branch
Firefox 50
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox47 unaffected, firefox48 unaffected, firefox49 unaffected, firefox50 verified)

Details

(Whiteboard: [multiviewport] [reserve-rdm])

Attachments

(1 attachment)

[Affected versions]:
- Firefox 50.0a1 (2016-07-20)

[Affected platforms]:
- Windows 10 x64, Mac OS X 10.9.5, Ubuntu 16.04 x64

[Steps to reproduce]:
1. Launch Firefox.
2. From about:config, enable the devtools.responsive.html.enabled pref.
3. Enable RDM.
4. Hoover the mouse over the touch event button.

[Expected result]:
- A tooltip is displayed.

[Actual result]:
- Nothing happens. 

[Regression range]:
- This is not a regression since the issue is reproducible from when the touch event button was first introduced.
QA Whiteboard: [qe-rdm]
Flags: qe-verify+
Priority: -- → P3
Whiteboard: [multiviewport] [triage] → [multiviewport] [reserve-rdm]
Assignee: nobody → bchabod
Status: NEW → ASSIGNED
Nothing much to say, just a quick fix to add the tooltip!
I've made the choice to change it if the touch simulation mode is already enabled, just tell me if you prefer a single label like "switch touch simulation mode".
Attachment #8773343 - Flags: review?(jryans)
Comment on attachment 8773343 [details] [diff] [review]
Patch - add a tooltip for the touch simulation button

Review of attachment 8773343 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, thanks for working on it!
Attachment #8773343 - Flags: review?(jryans) → review+
Given this try push is a success, I guess we're good to go:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=27a8311dda2d
Keywords: checkin-needed
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/fx-team/rev/6348d34d8643
Add a tooltip for the touch simulation button, r=jryans
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/6348d34d8643
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 50
Iteration: --- → 50.4 - Aug 1
Priority: P3 → P1
The tooltip is correctly displayed on Firefox 50.0a1 (2016-07-28) and on Windows 10 x64, Mac OS X 10.9.5 and on Ubuntu 16.04 x64.
I am marking this issue Verified Fixed.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.