"Relative links" should really be "Related links"

VERIFIED FIXED in mozilla1.0

Status

SeaMonkey
Page Info
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: Sören 'Chucker' Kuklau (gone), Assigned: Mike Kowalski)

Tracking

Trunk
mozilla1.0

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: ready to checkin)

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

16 years ago
According to http://www.w3.org/TR/html401/struct/links.html#adef-rel , the
rel="" attribute "describes the relationship from the current document to the
anchor specified by the href attribute. The value of this attribute is a
space-separated list of link types." The _relationship_, not the _relativity_.
Thus, in Page Info's Links tab, it should say "Related Link", not "Relative
Link" in the Type column when having <link> tags.
*** Bug 128840 has been marked as a duplicate of this bug. ***
Thought I mentioned this in one of the other open page info bugs, but evidently 
not.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Should be a one-liner to xpfe/browser/resources/locale/en-
US/pageInfo.properties, but I need to my home machine to generate it.
(Assignee)

Comment 4

16 years ago
Created attachment 72476 [details]
patch that needs diff
(Assignee)

Comment 5

16 years ago
Created attachment 72485 [details]
patch that needs diff

I changed Related Links to Related Link. Since there's 1 related link it should
be "Related Link".
Created attachment 72531 [details] [diff] [review]
diff of that patch
Attachment #72476 - Attachment is obsolete: true
Attachment #72485 - Attachment is obsolete: true
Comment on attachment 72531 [details] [diff] [review]
diff of that patch

r=choess, and probably mozbot
Attachment #72531 - Flags: review+
(Assignee)

Comment 8

16 years ago
taking bug
Assignee: db48x → mikejk
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

16 years ago
Keywords: mozilla1.0
OS: Windows XP → All
Hardware: PC → All
Whiteboard: Have r=, looking for sr=
Target Milestone: --- → mozilla1.0

Comment 9

16 years ago
Comment on attachment 72531 [details] [diff] [review]
diff of that patch

sr=jag
Attachment #72531 - Flags: superreview+

Comment 10

16 years ago
Comment on attachment 72531 [details] [diff] [review]
diff of that patch

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #72531 - Flags: approval+
(Assignee)

Updated

16 years ago
Whiteboard: Have r=, looking for sr= → ready to checkin
(Assignee)

Comment 11

16 years ago
fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.