Port bug 1262731 to IB and TB - Don't use a separate ICU data file on Windows

RESOLVED FIXED in Thunderbird 50.0

Status

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Paenglab, Assigned: Paenglab)

Tracking

unspecified
Thunderbird 50.0
Unspecified
Windows

Thunderbird Tracking Flags

(thunderbird47 unaffected, thunderbird48 fixed, thunderbird49 fixed, thunderbird50 fixed, thunderbird_esr45 unaffected)

Details

Attachments

(1 attachment)

From bug 1262731: "It's a mix of Firefox and Thunderbird, and even one SeaMonkey. It's mostly in 48.0a1, which suggests it's gotten a lot more frequent recently."
Posted patch icu.patchSplinter Review
Straight port from FX.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8773351 - Flags: review?(aleth)
Comment on attachment 8773351 [details] [diff] [review]
icu.patch

Review of attachment 8773351 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #8773351 - Flags: review?(aleth) → review+
Comment on attachment 8773351 [details] [diff] [review]
icu.patch

[Approval Request Comment]
Regression caused by (bug #): see linked bug
User impact if declined: topcrash!
Risk to taking this patch (and alternatives if risky): just following m-c here
Attachment #8773351 - Flags: approval-comm-beta?
Attachment #8773351 - Flags: approval-comm-aurora?
Duplicate of this bug: 1288651
Duplicate of this bug: 1288651
Pushed to fix bustage

https://hg.mozilla.org/comm-central/rev/c5465a63afb3
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 50.0
Attachment #8773351 - Flags: approval-comm-beta?
Attachment #8773351 - Flags: approval-comm-beta+
Attachment #8773351 - Flags: approval-comm-aurora?
Attachment #8773351 - Flags: approval-comm-aurora+
Beta (TB 48):
https://hg.mozilla.org/releases/comm-beta/rev/ecc56fcf0f7e
Landed with DONTBUILD, next automated blocklist update (tomorrow?) will compile it.
You need to log in before you can comment on or make changes to this bug.