Frequent Intermittent crashes

RESOLVED INVALID

Status

()

RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: walker1, Unassigned)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8773424 [details]
Firefox 47.0.1  Crash Raw Dump.txt

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160623154057

Steps to reproduce:


Just normal surfing activity resulting in crashes. I have tried the following

1. Firefox crashes intermittent. Other programs and/or browsers as well but mostly Firefox.

2. I cannot tell if the same thing occurs in safe mode since it is intermittent

3. ran memtest86+ on the RAM and found lots of errors. Replaced RAM and that seemed to do the trick for about a week. Crashes began again today. I ran memtest86+ again and found no errors (the same as after I replaced all RAM).

4. ran a couple of virus/malware checkers and found nothing

5. I am running fully updated windows XP pro

6. Last crash report ID is: bp-6ce225be-36ff-4e46-961a-3f2142160720 I have a copy of the raw data dump but it is too long to paste into this post 

Also I have done a clean reinstall of Firefox as well as tried the "refresh" firefox.

I do not have "hardware acceleration" enabled


I can add that today I ran a motherboard diagnostics tool and found no errors. I am including a copy of the file dump for one of the crashes.

A suggestion was made:
There was a recent lax in blocked NVIDIA drivers and I think that yours { webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 6200 Direct3D9 vs_3_0 ps_3_0) } may fall under that category. 

Originally the blocklist entry blocked all versions less than version 8.17.11.8265 and since you already disabled hardware acceleration and it still happening we can file a bug here https://mzl.la/2a1qfUX

EDIT*
happy to assist with this, in the bug we will need an example url where this happens and the hardware, version (64bit or 32bit).



Actual results:

No changes


Expected results:

fully functional browser
Reporter: Are all your other crashes the same as the stack that is mentioned in #6? That stack maps to Bug 1277310.
Flags: needinfo?(walker1)
(Reporter)

Comment 2

2 years ago
Here are Report IDs for the last few crashes. The topmost happened while I was trying to write this post.

bp-555f7a9a-f451-4cdb-ab45-0548f2160721	1 minute ago
bp-e5fa8ad4-3670-48e4-8c23-dbba42160721	30 minutes ago
bp-3530f63e-762f-4399-b624-7bd6d2160721	1 hour ago
bp-180d2916-23b8-4eb2-b0a2-7b2482160721	2 hours ago
bp-a380369d-0600-478a-afd0-931982160721	5 hours ago
bp-c4ad0586-b06b-4b54-b0f2-72a2d2160721	16 hours ago
bp-87764809-2efa-4479-a744-d528b2160721	16 hours ago
bp-e4d64149-c737-42ed-97f9-48b732160720	20 hours ago
bp-6ce225be-36ff-4e46-961a-3f2142160720	1 day ago
bp-f7785165-9cf2-4360-b360-936142160720
Flags: needinfo?(walker1)
(In reply to walker1 from comment #2)
> Here are Report IDs for the last few crashes. The topmost happened while I
> was trying to write this post.
> 
> bp-555f7a9a-f451-4cdb-ab45-0548f2160721	1 minute ago
> bp-e5fa8ad4-3670-48e4-8c23-dbba42160721	30 minutes ago
> bp-3530f63e-762f-4399-b624-7bd6d2160721	1 hour ago
> bp-180d2916-23b8-4eb2-b0a2-7b2482160721	2 hours ago
> bp-a380369d-0600-478a-afd0-931982160721	5 hours ago
> bp-c4ad0586-b06b-4b54-b0f2-72a2d2160721	16 hours ago
> bp-87764809-2efa-4479-a744-d528b2160721	16 hours ago
> bp-e4d64149-c737-42ed-97f9-48b732160720	20 hours ago
> bp-6ce225be-36ff-4e46-961a-3f2142160720	1 day ago
> bp-f7785165-9cf2-4360-b360-936142160720

Thanks for the reports. The stacks seem to be all different, so right now I cannot tell exactly what may be the root cause.

Bug 1284322 for the NVIDIA blacklist is right now only on Nightly, so if you are running release that shouldn't be the cause of these crashes.

Do the crashes happen when you are interacting with the browser (scrolling, mouse movements) and have they ever happen when the browser is idle? Also do you have anti-virus programs installed on your machine?
Flags: needinfo?(walker1)
(Reporter)

Comment 4

2 years ago
I wish I could be more help but I am not much of a computer guru. I haven't found an actual "trigger" for these crashes yet. I have also noticed other programs crashing as well. I started to use Explorer (v8, I think) about a week after Firefox started crashing just to see if it would work and it started crashing also. I haven't used Explorer in years so I can't tell if it started at the same time as the upgrade. I have been trying to install/debug MikTex the last couple of days and many times the installer will crash before it completes. I still haven't gotten it installed (but that is expected. It is a terrible program). But I wasn't expecting the crashes. 

I also went back and looked at the crash history and they started on 7/1/16 (right around the installation of version 47.0.1) and have happened regularly since then. Prior to that, the only crash was in January of 2015, and rarely before that.

I have been running in safe mode for about an hour now. I will keep it that way until something happens (or doesn't). As you can see from the crash history below something should be coming around any time now...

bp-27c5dab0-df8c-44ad-9a83-256102160721
	7/21/2016	5:04 PM
bp-555f7a9a-f451-4cdb-ab45-0548f2160721
	7/21/2016	3:46 PM
bp-e5fa8ad4-3670-48e4-8c23-dbba42160721
	7/21/2016	3:17 PM
bp-3530f63e-762f-4399-b624-7bd6d2160721
	7/21/2016	2:19 PM
bp-180d2916-23b8-4eb2-b0a2-7b2482160721
	7/21/2016	1:33 PM
bp-a380369d-0600-478a-afd0-931982160721
	7/21/2016	10:28 AM
bp-c4ad0586-b06b-4b54-b0f2-72a2d2160721
	7/21/2016	12:00 AM
bp-87764809-2efa-4479-a744-d528b2160721
	7/20/2016	11:30 PM
bp-e4d64149-c737-42ed-97f9-48b732160720
	7/20/2016	7:52 PM
bp-6ce225be-36ff-4e46-961a-3f2142160720
	7/20/2016	2:42 PM
bp-f7785165-9cf2-4360-b360-936142160720
	7/20/2016	2:15 PM
bp-b59e40eb-332f-4dd5-bd78-6f1fc2160710
	7/10/2016	3:38 PM
bp-bb6f7a59-6978-43d8-bef2-c27352160710
	7/10/2016	3:38 PM
bp-a5cb07e7-0e16-4eea-90db-f96d32160709
	7/9/2016	12:34 PM
bp-46ef6a23-9bb3-4283-acb4-955962160709
	7/9/2016	5:40 AM
bp-62d32b56-2347-4a48-b7fc-b775c2160709
	7/9/2016	5:33 AM
bp-5031be38-f4a8-4c64-b270-352082160709
	7/9/2016	5:26 AM
bp-dd12dedf-fafb-45a0-bc9b-c48002160709
	7/9/2016	1:27 AM
bp-8ff88404-fb88-4414-9f11-202eb2160709
	7/8/2016	8:23 PM
bp-48915308-4c4c-4306-840e-b919c2160708
	7/8/2016	5:11 PM
bp-e91e7431-95a6-4f56-84ca-74ca02160708
	7/8/2016	12:59 PM
bp-e8d8bfcc-5b75-4b55-9c54-f1ba22160707
	7/7/2016	7:52 PM
bp-d9184dba-5bd4-415d-8eec-9e7ef2160707
	7/7/2016	7:38 PM
bp-91426538-fa6e-488e-ab4f-58f2f2160707
	7/7/2016	3:05 PM
bp-c1cac6bd-b3e5-4151-a58a-95e3c2160707
	7/7/2016	2:08 PM
bp-11a01b39-944b-4c50-a3c0-fdd512160707
	7/7/2016	2:07 PM
bp-81b9f408-3494-4cce-9160-e708e2160707
	7/7/2016	2:06 PM
bp-78f42ee2-76bb-4209-83de-53f182160707
	7/7/2016	2:05 PM
bp-27de5ac0-a97c-4b80-96a9-6dc0f2160707
	7/7/2016	11:26 AM
bp-6597cd1e-af1a-436f-8cee-eb9e52160707
	7/7/2016	9:18 AM
bp-f9dc850c-0d48-494b-992b-76c5e2160707
	7/7/2016	9:14 AM
bp-c35ca063-9157-40d5-ab7f-70a7e2160707
	7/7/2016	9:08 AM
bp-ff69cb3c-a0fa-4a06-bb56-555b32160706
	7/6/2016	7:40 PM
bp-97eef42f-30f2-43e3-be4d-a04462160706
	7/6/2016	7:33 PM
bp-37289d80-b777-4d49-a9a2-80e652160706
	7/6/2016	7:30 PM
bp-6438b3d7-fa1c-4abc-83e7-198a82160706
	7/6/2016	7:22 PM
bp-9cdefaa8-60a4-4428-a40b-1b0782160706
	7/6/2016	7:15 PM
bp-b5b0b1a0-4fa8-4c64-a106-2727c2160706
	7/6/2016	6:01 PM
bp-62b201b8-b225-4efb-98ec-507532160706
	7/6/2016	4:17 PM
bb904fed-9ea8-4a02-9b11-d930266bf994
	7/6/2016	4:16 PM
bp-ae38b9a9-96ba-42f5-b68b-b8b352160706
	7/6/2016	4:06 PM
bp-4d83e154-b961-47d1-8e4f-928d92160706
	7/6/2016	11:14 AM
bp-c8713604-4ea5-4e3a-8f28-8a7bf2160706
	7/5/2016	10:50 PM
bp-5bd3c553-c546-418c-9e51-170282160706
	7/5/2016	10:31 PM
bp-6440f27a-b425-4fdb-bdd1-266e82160706
	7/5/2016	10:21 PM
bp-78878725-4a2f-4e7d-97c7-58f3a2160705
	7/5/2016	1:27 PM
bp-2389a532-c0a1-481e-ae51-6cc832160705
	7/5/2016	1:14 PM
bp-03f7f81e-c701-4bb4-b264-c1be42160705
	7/5/2016	10:26 AM
bp-a5cd01b6-e9f4-4da7-b129-99dbc2160705
	7/5/2016	9:54 AM
bp-502269ff-6177-41ce-b8f7-73bab2160703
	7/3/2016	9:40 AM
bp-d31dfb4e-7594-4de3-bef4-7be592160702
	7/2/2016	3:02 PM
bp-381187d8-70fe-4960-a232-5fdc72160702
	7/2/2016	11:25 AM
bp-9b8f2bd8-3fba-4a21-aa3b-3c8b12160702
	7/2/2016	11:20 AM
bp-9566b219-8a99-497f-b297-6c1ee2160702
	7/2/2016	11:16 AM
bp-e3500b6c-fe59-48c5-8a4f-533862160702
	7/2/2016	11:15 AM
bp-610b8a62-472d-44a0-a5e8-2f7f02160702
	7/2/2016	11:02 AM
bp-2854615f-7e53-401b-8c49-83ef52160701
	7/1/2016	6:56 PM
bp-5758bc4e-3aeb-4b51-a1fe-f663b2160701
	7/1/2016	6:55 PM
bp-4cfbb889-72d1-40e3-b53d-1b2fb2160701
	7/1/2016	6:54 PM
bp-c43a0ce6-b46a-4cb6-9af4-463c72160701
	7/1/2016	6:53 PM
bp-270a9842-b5f2-4cc8-8ff6-4d23a2160701
	7/1/2016	6:35 PM
bp-d37ac67b-7d48-4a05-9e9c-68f062160701
	7/1/2016	4:14 PM
bp-f53da669-822b-404b-bd0f-61e7c2160701
	7/1/2016	4:10 PM
bp-824425ff-1089-4c0d-8093-9f28e2160701
	7/1/2016	4:08 PM
bp-5e83945f-c5d5-465f-ac5a-13ff42160701
	7/1/2016	4:08 PM
bp-983650e5-2f42-4aaf-80bc-973162160701
	7/1/2016	3:11 PM
(Reporter)

Comment 5

2 years ago
Ok this crash happened while in safemode:
bp-f5570b89-b0d3-4d75-9cf8-892fc2160721

At this url:
http://answers.microsoft.com/en-us/windows/forum/windows_8-winapps/windows-api-error-5/7d675d61-25e7-4ae3-9834-2b9a0d2fa31b?auth=1

I was researching a bug in the MikTex install "Windows API error 5: Access is denied" and only reading the website, no downloading or anything.

Comment 6

2 years ago
If different browsers crash too, it could be an issue with your hardware (maybe some updates).
In general, random crashes are due to bad hardware or sometimes malwares.
(Reporter)

Comment 7

2 years ago
I've been trying different things in that regard:
1. ran memtest86+ three times since this started. First time found several thousand errors with RAM. I replaced all 3GB and re-ran the test. No errors. Re-ran test yesterday and still found no errors.

2. Ran an ASUS motherboard test utility and found no errors with motherboard.

3. I re-installed the driver for my NVIDIA GeForce 6200 video card. I was not able to find a more up to date driver. This failed on the first try. There was a problem with NVCPL.dll file. I did two things at that point: I went back to microsoft update page and discovered that my Microsoft.NET Framework 1.1 was not actually updated and would not install. I was able to fix that issue. Second, I ran the Microsoft File Checker utility and it did update files, but I am not sure what/how many since the utility doesn't report that back to me. I was able to re-install the NVIDIA driver afterwards.

4.  I have run several antivirus/malware software checkers. So far no problems in that area. Of course these are freeware versions and not pro versions.

So, that is where I am this morning. I left the Firefox browser and Thunderbird open all night and so far haven't had any crashes, but that has happened before.
(Reporter)

Comment 8

2 years ago
Crash happened about a minute after the above post:
bp-0cffde6e-8772-431a-8cec-c7f672160722

at this url:
https://accounts.google.com/ServiceLogin?service=mail&continue=https://mail.google.com/mail/#identifier

I was trying to logon to Google mail

Comment 9

2 years ago
Can you type about:support in the location bar and copy here the "graphics" section.
(Reporter)

Comment 10

2 years ago
and this one happened right after that:
bp-a85368b3-aef4-4b9c-98f1-edb772160722

I don't have the url since I can't remember where I was when this happened. I wasn't doing/clicking anything. History is not save as a preference.
(Reporter)

Comment 11

2 years ago
Adapter Description	NVIDIA GeForce 6200
Adapter Drivers	nv4_disp
Adapter RAM	Unknown
Asynchronous Pan/Zoom	none
Device ID	0x0221
DirectWrite Enabled	false (0.0.0.0)
Driver Date	3-21-2013
Driver Version	6.14.13.790
GPU #2 Active	false
GPU Accelerated Windows	0/1 Basic (OMTC)
Subsys ID	226a1682
Supports Hardware H264 Decoding	No; Failed to create H264 decoder
Vendor ID	0x10de
WebGL Renderer	Google Inc. -- ANGLE (NVIDIA GeForce 6200 Direct3D9 vs_3_0 ps_3_0)
windowLayerManagerRemote	true
AzureCanvasAccelerated	0
AzureCanvasBackend	skia
AzureContentBackend	cairo
AzureFallbackCanvasBackend	cairo
(Reporter)

Comment 12

2 years ago
The latest:
Report ID 	Submitted
bp-2a7909ec-4830-41a1-a9a5-9dc1e2160722

URL:
http://www.comicartcommunity.com/gallery/categories.php?cat_id=310&page=2

Also, are you able to get information from the crash reports or do I need to paste a screenshot of the whole page(s)?

Comment 13

2 years ago
walker1: I did desktop support for a number of years. The reason why most companies just reimage a computer when they start having the problems that your PC is, is because you will be at it for weeks on end trying to track down the root cause. Especially on older machines with older operating systems. Running scans and stuff don't tell you everything thus may be missing the root cause. If a reimage doesn't work then the end user is given a brand new PC in just about all corporate environments.

You're issue could be hardware related. Like anything the hardware inside your PC degrades after time and the only solution is to get new hardware if you know for sure which part it is. Your issue could also be that the Windows XP has some corrupt files in it's core (software files also degrade over time), and the best thing to do about that is to backup your files and reimage your computer. 

All in all, I don't think this is a Firefox issue since several other software programs are crashing as well. And more then likely your install of Windows XP is a good 10 years old which means some operating system files may have gone bad.

Comment 14

2 years ago
I agree with  julesmyers2011, it's more an issue with your hardware than Firefox (or any different app).
You should ask support on a website related to Windows maybe.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(walker1)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.