web.whatsapp.com isn't working on Fx Nightly with e10s off

RESOLVED INVALID

Status

()

Core
DOM
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: edwong, Unassigned)

Tracking

({regression, regressionwindow-wanted})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
1. with nightly goto: https://web.whatsapp.com/
2. use your phone and in menu, choose 'web whatsapp'
3. scan the QR code

actual: nothing happens and spins cursor with blank page

expected: it should sign in like chrome.

I haven't tested other channels.
Is this a regression?
(Reporter)

Comment 2

a year ago
yes, the page used to load with my messages and work properly
Does it still work in release/beta/aurora? If so, we need regression range here. 
Or has the page changed so that it is broken?
Flags: needinfo?(edwong)

Updated

a year ago
Keywords: regression, regressionwindow-wanted
(Reporter)

Comment 4

a year ago
regression is in nightly, unable to repro in today's aurora
Flags: needinfo?(edwong)
I tested this issue on Mac OS X 10.10 with Nightly 50.0a1 (2016-07-21) and I can't reproduce it. On what OS you tested?
Flags: needinfo?(edwong)
(Reporter)

Comment 6

a year ago
i'm on mac 10.11.  I see this in the console:

The Application Cache API (AppCache) is deprecated and will be removed at a future date.  Please consider using ServiceWorker for offline support.web.whatsapp.com
An IndexedDB transaction that was not yet complete has been aborted due to page navigation.vendor2_e6cb430ba1033252c76e.js:8:8114
AbortErrorvendor2_e6cb430ba1033252c76e.js:8:6238
Content Security Policy: The page’s settings blocked the loading of a resource at self (“script-src https://web.whatsapp.com 'unsafe-eval' https://ajax.googleapis.com”).web.whatsapp.com:1
Content Security Policy: The page’s settings blocked the loading of a resource at https://web.whatsapp.com/wa.appcache (“default-src 'none'”).(unknown)
Flags: needinfo?(edwong)
(Reporter)

Comment 7

a year ago
ok - no repro in a new profile.  Looks like maybe addon collision. I'm trying that now.
(Reporter)

Comment 8

a year ago
More data: with addons disabled, e10s on it loads whatsapp, e10s off page won't load
(Reporter)

Updated

a year ago
Summary: web.whatsapp.com isn't working on Fx Nightly → web.whatsapp.com isn't working on Fx Nightly with e10s off
Tested on Mac OS X 10.10 with FF 50.0a1 (2016-07-24) with e10s off I can load whatsapp but I see this is browser console: 

The Application Cache API (AppCache) is deprecated and will be removed at a future date.  Please consider using ServiceWorker for offline support.search
An IndexedDB transaction that was not yet complete has been aborted due to page navigation.vendor2_7e0b6fa7dbb6cd6196d9.js:15:12218

Please note that I can load whatsapp with e10s disabled.
Edwin can you please run mozregression, based on the fact that I can't reproduce this, and provide a regression window?
Flags: needinfo?(edwong)
(Reporter)

Comment 11

a year ago
I haven't been able to repro with clean profiles.  I'll keep trying.
(Reporter)

Comment 12

a year ago
I'm not longer able to repro this on nightly - with or without e10s. closing.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(edwong)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.