Internet Keywords search should use Default Search Engine

VERIFIED DUPLICATE of bug 53171

Status

VERIFIED DUPLICATE of bug 53171
17 years ago
10 years ago

People

(Reporter: bill+mozilla-bugzilla, Assigned: samir_bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

What I really want to be able to do is to type some space-separated words in the
URL text box and hit enter, and get a Google search. 

I know I can edit prefs.js to get that, but if the user has already selected his
default search engine, he's probably not interested in getting results from a
different one if he uses a different piece of the UI to get there.

Per bug 58867, Internet Keywords is the path through which these searches should
be handled.

Comment 1

17 years ago
You can do it just by pressing the up arrow before pressing enter.
Yes, there are lots of ways to get it to work (I hack prefs.js) - I'm just
thinking of the average user and UI coherency.
For a handful of results I tried I get exactly the same results with Netscape
Search and the search button as I do with internet keywords (hitting return). 
So if someone wants the default IK behavior, they can just select Netscape
Search as their default search engine and lose nothing.

Comment 4

17 years ago

*** This bug has been marked as a duplicate of 53171 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Verifying duplicate.  See bug 137026 for a better idea, anyway.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.