Intermittent page-worker/main.test page load | Test timed out (after: START)

RESOLVED FIXED in Firefox 50

Status

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: intermittent-bug-filer, Unassigned)

Tracking

({intermittent-failure})

unspecified
mozilla52
intermittent-failure

Firefox Tracking Flags

(firefox50 fixed, firefox51 fixed, firefox52 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

would it be possible that this is caused by bug 1288480 ?
Flags: needinfo?(aswan)

Comment 2

2 years ago
(In reply to Carsten Book [:Tomcat] from comment #1)
> would it be possible that this is caused by bug 1288480 ?

It is very unlikely, the code path changed in bug 1288480 is never invoked in this test.
Luca, are you familiar with this test?  (I'm not even sure how to run the jetpack tests locally)
Flags: needinfo?(aswan) → needinfo?(lgreco)
6 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 3
* fx-team: 2
* ash: 1

Platform breakdown:
* windows7-32-vm: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1288619&startday=2016-07-18&endday=2016-07-24&tree=all
The failure doesn't seem to be related to Bug 1288480.

I tried to reproduce it locally (even by trying to run the test on a win32 pgo build, which is where it seems that it fails), but without any luck.
Flags: needinfo?(lgreco)
41 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 14
* fx-team: 13
* mozilla-central: 8
* autoland: 6

Platform breakdown:
* windows7-32-vm: 37
* windowsxp: 3
* windows8-64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1288619&startday=2016-07-25&endday=2016-07-31&tree=all
59 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 25
* autoland: 10
* mozilla-central: 9
* fx-team: 9
* mozilla-aurora: 5
* ash: 1

Platform breakdown:
* windows7-32-vm: 50
* windowsxp: 5
* windows8-64: 2
* android-4-3-armv7-api15: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1288619&startday=2016-08-01&endday=2016-08-07&tree=all
48 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 16
* mozilla-central: 10
* autoland: 9
* fx-team: 8
* mozilla-aurora: 5

Platform breakdown:
* windows7-32-vm: 45
* windowsxp: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1288619&startday=2016-08-08&endday=2016-08-14&tree=all
42 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 11
* mozilla-aurora: 9
* fx-team: 9
* autoland: 9
* mozilla-central: 4

Platform breakdown:
* windows7-32-vm: 37
* windowsxp: 4
* windows8-64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1288619&startday=2016-08-15&endday=2016-08-21&tree=all
42 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-aurora: 12
* mozilla-inbound: 8
* fx-team: 8
* mozilla-central: 7
* autoland: 6
* oak: 1

Platform breakdown:
* windows7-32-vm: 38
* windows8-64: 2
* windowsxp: 1
* osx-10-10: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1288619&startday=2016-08-22&endday=2016-08-28&tree=all
45 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-aurora: 13
* mozilla-inbound: 11
* mozilla-central: 9
* autoland: 6
* fx-team: 5
* oak: 1

Platform breakdown:
* windows7-32-vm: 24
* windowsxp: 19
* windows8-64: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1288619&startday=2016-08-29&endday=2016-09-04&tree=all
53 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 13
* mozilla-aurora: 13
* autoland: 12
* mozilla-central: 9
* fx-team: 5
* ash: 1

Platform breakdown:
* windowsxp: 30
* windows7-32-vm: 22
* windows8-64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1288619&startday=2016-09-05&endday=2016-09-11&tree=all
45 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 13
* autoland: 13
* mozilla-aurora: 11
* mozilla-central: 4
* fx-team: 3
* ash: 1

Platform breakdown:
* windows7-32-vm: 29
* windowsxp: 15
* osx-10-10: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1288619&startday=2016-09-12&endday=2016-09-18&tree=all
33 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-beta: 11
* mozilla-inbound: 7
* mozilla-aurora: 5
* mozilla-central: 4
* fx-team: 3
* autoland: 3

Platform breakdown:
* windowsxp: 13
* windows7-32-vm: 11
* windows8-64: 8
* osx-10-10: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1288619&startday=2016-09-19&endday=2016-09-25&tree=all
18 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-aurora: 7
* mozilla-beta: 6
* fx-team: 3
* mozilla-inbound: 1
* autoland: 1

Platform breakdown:
* windows7-32-vm: 8
* windows8-64: 6
* windowsxp: 4

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1288619&startday=2016-09-26&endday=2016-10-02&tree=all
25 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-beta: 13
* mozilla-inbound: 3
* mozilla-central: 3
* mozilla-aurora: 2
* fx-team: 2
* autoland: 2

Platform breakdown:
* windows8-64: 11
* windows7-32-vm: 8
* windowsxp: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1288619&startday=2016-10-03&endday=2016-10-09&tree=all
35 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-beta: 15
* mozilla-inbound: 11
* mozilla-aurora: 5
* autoland: 3
* mozilla-central: 1

Platform breakdown:
* windows8-64: 17
* windows7-32-vm: 11
* windowsxp: 7

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1288619&startday=2016-10-10&endday=2016-10-16&tree=all
20 automation job failures were associated with this bug yesterday.

Repository breakdown:
* autoland: 8
* mozilla-beta: 5
* mozilla-inbound: 4
* mozilla-central: 1
* mozilla-aurora: 1
* fx-team: 1

Platform breakdown:
* windows7-32-vm: 13
* windows8-64: 4
* windowsxp: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1288619&startday=2016-10-18&endday=2016-10-18&tree=all
20 automation job failures were associated with this bug yesterday.

Repository breakdown:
* autoland: 6
* try: 4
* mozilla-inbound: 4
* fx-team: 3
* mozilla-central: 2
* mozilla-beta: 1

Platform breakdown:
* windows7-32-vm: 17
* windowsxp: 2
* osx-10-10: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1288619&startday=2016-10-19&endday=2016-10-19&tree=all
22 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 8
* autoland: 4
* mozilla-beta: 3
* mozilla-aurora: 3
* mozilla-central: 2
* fx-team: 2

Platform breakdown:
* windows7-32-vm: 18
* windows8-64: 3
* windowsxp: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1288619&startday=2016-10-20&endday=2016-10-20&tree=all
102 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* autoland: 30
* mozilla-inbound: 28
* mozilla-beta: 14
* mozilla-central: 10
* fx-team: 8
* mozilla-aurora: 7
* try: 5

Platform breakdown:
* windows7-32-vm: 78
* windows8-64: 12
* windowsxp: 9
* linux64: 2
* osx-10-10: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1288619&startday=2016-10-17&endday=2016-10-23&tree=all
22 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 7
* autoland: 6
* try: 3
* mozilla-central: 2
* mozilla-aurora: 2
* mozilla-beta: 1
* fx-team: 1

Platform breakdown:
* windows7-32-vm: 16
* windows8-64: 3
* linux64: 2
* windowsxp: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1288619&startday=2016-10-24&endday=2016-10-24&tree=all
Looking back at inbound's history, the first instance came shortly after a set of worker-related patches of baku's landed - bug 1288033, bug 1288031. Any thoughts, baku?
Flags: needinfo?(amarchesini)
is it possible that this is related to bug 1288708?  that summary is " Intermittent page-worker/main.test postMessage | Test timed out (after: START)"
Yes, they generally both happen as a pair.

Updated

2 years ago
See Also: → bug 1288708
96 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* autoland: 31
* mozilla-inbound: 26
* try: 13
* mozilla-central: 11
* mozilla-aurora: 8
* mozilla-beta: 5
* fx-team: 2

Platform breakdown:
* windows7-32-vm: 74
* linux64: 9
* windowsxp: 8
* windows8-64: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1288619&startday=2016-10-24&endday=2016-10-30&tree=all
19 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 5
* autoland: 5
* try: 4
* mozilla-central: 3
* fx-team: 2

Platform breakdown:
* windows7-32-vm: 15
* linux64: 2
* windowsxp: 1
* windows8-64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1288619&startday=2016-10-31&endday=2016-10-31&tree=all
15 automation job failures were associated with this bug yesterday.

Repository breakdown:
* autoland: 9
* mozilla-inbound: 4
* try: 1
* mozilla-aurora: 1

Platform breakdown:
* windows7-32-vm: 11
* osx-10-10: 2
* windowsxp: 1
* windows8-64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1288619&startday=2016-11-03&endday=2016-11-03&tree=all
here is a clip from a recent log [1]

23:00:39     INFO -  TEST-START | page-worker/main.test page load
23:00:40     INFO -  JavaScript error: resource://test-page-worker-at-jetpack/page-worker/data/page.js, line 5: ReferenceError: addon is not defined
23:00:40     INFO -  TEST-INFO | [JavaScript Error: "ReferenceError: addon is not defined" {file: "resource://test-page-worker-at-jetpack/page-worker/data/page.js" line: 5}]
23:00:40     INFO -  @resource://test-page-worker-at-jetpack/page-worker/data/page.js:5:1
23:00:40     INFO -  JavaScript error: resource://test-page-worker-at-jetpack/page-worker/data/page.js, line 2: ReferenceError: addon is not defined
23:00:40     INFO -  TEST-INFO | [JavaScript Error: "ReferenceError: addon is not defined" {file: "resource://test-page-worker-at-jetpack/page-worker/data/page.js" line: 2}]
23:00:40     INFO -  @resource://test-page-worker-at-jetpack/page-worker/data/page.js:2:3
23:00:40     INFO -  EventListener.handleEvent*@resource://test-page-worker-at-jetpack/page-worker/data/page.js:1:1
23:05:39  WARNING -  TEST-UNEXPECTED-FAIL | page-worker/main.test page load | Test timed out (after: START)
23:05:39     INFO -  TEST-INFO | Traceback (most recent call last):
23:05:39     INFO -    File "resource://gre/modules/commonjs/sdk/timers.js", line 40, in notify
23:05:39     INFO -      callback.apply(null, args);
23:05:39     INFO -    File "resource://gre/modules/commonjs/sdk/deprecated/unit-test.js", line 506, in tiredOfWaiting
23:05:39     INFO -      self.console.testMessage(false, false, self.test.name,
23:05:39     INFO -    File "resource://gre/modules/commonjs/sdk/test/harness.js", line 541, in testMessage
23:05:39     INFO -      this.trace();
23:05:39     INFO -  TEST-PASS | page-worker/main.test page load | This test is done.
23:05:39     INFO -  TEST-PASS | page-worker/main.test page load | There was a clean UI.
23:05:39     INFO -  TEST-END | page-worker/main.test page load

as a note, this happens primarily on windows 7 (which is run in AWS inside a VM)- and once in a while on other OS types/versions.

the combination of this bug and bug 1288708 make this the #2 intermittent orange (20+ instances/day).  If we don't hear anything by next week, I will assume that there is little interest in this test and there is no problem disabling it with a skip-if [2]?



[1] https://archive.mozilla.org/pub/firefox/tinderbox-builds/autoland-win32/1478229981/autoland_win7_vm_test-mochitest-jetpack-bm140-tests1-windows-build149.txt.gz
[2] https://dxr.mozilla.org/mozilla-central/source/addon-sdk/source/test/addons/jetpack-addon.ini#31
23 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-central: 6
* autoland: 6
* try: 5
* mozilla-inbound: 5
* mozilla-beta: 1

Platform breakdown:
* windows7-32-vm: 19
* windows8-64: 3
* linux64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1288619&startday=2016-11-04&endday=2016-11-04&tree=all
100 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* autoland: 35
* mozilla-inbound: 30
* try: 16
* mozilla-central: 14
* fx-team: 2
* mozilla-release: 1
* mozilla-beta: 1
* mozilla-aurora: 1

Platform breakdown:
* windows7-32-vm: 76
* windows8-64: 11
* windowsxp: 5
* osx-10-10: 5
* linux64: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1288619&startday=2016-10-31&endday=2016-11-06&tree=all
Comment hidden (mozreview-request)
Attachment #8809109 - Flags: review?(dtownsend) → review?(lgreco)
Flags: needinfo?(amarchesini)
17 automation job failures were associated with this bug yesterday.

Repository breakdown:
* autoland: 9
* mozilla-inbound: 6
* mozilla-central: 1
* mozilla-aurora: 1

Platform breakdown:
* windows8-64: 8
* windows7-32-vm: 6
* windowsxp: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1288619&startday=2016-11-09&endday=2016-11-09&tree=all
Comment on attachment 8809109 [details]
Bug 1288619 - disable page-worker test due to high intermittent rate.

Sounds good, lets disable it for now.
(nit: "tst" -> "test" in the patch summary message)  

I'm fighting with this test from a while now, I'm still not able to reproduce it locally and so I tried to get some additional details about what is happening when it fails by pushing to try with "--rebuild" (which is able to reproduce it consistently enough by re-running the mochitest-jetpack test suite at least 10 times per build).

When it fails, it seems that the SDK "sdk/content/page-worker/" module has never reached this line for the created page-worker: https://dxr.mozilla.org/mozilla-central/source/addon-sdk/source/lib/sdk/content/page-worker.js#130

The possible reasons seems to be:
- it has not received a "document-element-inserted" observer notification for the expected document
- none of the existents page seems to be related to the "document-element-inserted" document (e.g. the observer has received a document but it doesn't pass the check "contentWindow.document == target")

By looking at the logs that I collected when the test passes and when it fails, it looks like the intermittents can be related to some weird behavior of the windowless browser created and initialized as an about:blank in the PageWorker constructor (it wouldn't be the first time that the windowlessBrowser and/or "about:blank" show some weird behavior):
- https://dxr.mozilla.org/mozilla-central/source/addon-sdk/source/lib/sdk/content/page-worker.js#38
- https://dxr.mozilla.org/mozilla-central/source/addon-sdk/source/lib/sdk/content/page-worker.js#41-43

I'll keep fighting on it, I have the feeling that the actual issue is not far from what described above.
Attachment #8809109 - Flags: review?(lgreco) → review+
Comment hidden (mozreview-request)

Comment 35

2 years ago
mozreview-review
Comment on attachment 8809109 [details]
Bug 1288619 - disable page-worker test due to high intermittent rate.

https://reviewboard.mozilla.org/r/91756/#review92100

carry forward r+
Attachment #8809109 - Flags: review?(lgreco) → review?(jmaher)

Comment 36

2 years ago
mozreview-review
Comment on attachment 8809109 [details]
Bug 1288619 - disable page-worker test due to high intermittent rate.

https://reviewboard.mozilla.org/r/91756/#review92104

goofy mozreview, I guess I need to assign this to myself to carry over the r+ as I just changed a typo in the commit message!!!
Attachment #8809109 - Flags: review?(jmaher)
Attachment #8809109 - Attachment is obsolete: true
Created attachment 8809578 [details] [diff] [review]
pageworker.patch

updated patch with proper commit message.
Attachment #8809578 - Flags: review+

Comment 38

2 years ago
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/28dc1d71a791
disable page-worker test due to high intermittent rate. r=rpl
status-firefox50: --- → unaffected
status-firefox51: --- → affected
status-firefox52: --- → affected
status-firefox50: unaffected → affected

Comment 39

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/41a68b4d013c
status-firefox51: affected → fixed

Comment 40

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-release/rev/f8fc6ddf94ea
status-firefox50: affected → fixed

Comment 41

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/28dc1d71a791
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox52: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
48 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* autoland: 21
* mozilla-inbound: 17
* mozilla-central: 6
* try: 2
* mozilla-aurora: 2

Platform breakdown:
* windows7-32-vm: 23
* windows8-64: 16
* windowsxp: 7
* linux64: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1288619&startday=2016-11-07&endday=2016-11-13&tree=all
This appears to have been caused by 1285373.
As opposed to turning off the test, was any attempt made to backtrack and see what patch started causing the intermittent failures?
Blocks: 1285373
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
You did see that this got fixed and re-enabled in bug 1316875, right?
> You did see that this got fixed and re-enabled in bug 1316875, right?

No I did not. Thanks for pointing that out. That might help get to the bottom of why some other things were broken by 1285373.

I should have taken a look at the current state of the test (and noticed the see also bugs).
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.