links not marked visited when in frames

RESOLVED DUPLICATE of bug 78510

Status

()

P2
normal
RESOLVED DUPLICATE of bug 78510
17 years ago
16 years ago

People

(Reporter: bugzilla, Assigned: attinasi)

Tracking

({regression})

Trunk
Future
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

219.89 KB, text/plain
Details
939 bytes, application/octet-stream
Details
(Reporter)

Description

17 years ago
clicking on a link in the newsgroups subject doesn't mark the link visited. You
have to reload the entire page to get the visited effect. This used to work.

20020304
is this just bug 78510?
(Reporter)

Comment 2

17 years ago
nope. This is the same window, just different frameset. This used to work....

Comment 3

17 years ago
Changing QA contact
QA Contact: petersen → moied
I can reproduce the bug using 2002030508 build on WINXP. On IE 6.0 the link goes
from bold to normal when you click on them. Using Mozilla they always stay bold.
Keywords: regression
Priority: -- → P2
Target Milestone: --- → Future
I'd like to add my piece to this bug:

Opening a link in a new window doesn't mark the link in the original window as
'visited'
Opening a link in a new tab doesn't mark the link in the original tab as 'visited'.

This behaviour is -extremely- annoying.
This happens for me in Linux. It's not specifically a Windows 2000 problem.
(Reporter)

Updated

17 years ago
OS: Windows 2000 → All
Hardware: PC → All
Summary: links not marked visited → links not marked visited when in frames

Comment 7

16 years ago
QUESTION: Should the behavior in Comment#5, which has nothing to do with frames,
be separated out into a new bug? 

Comment 8

16 years ago
The Url makes the 1/08/03 Trunk build crash. I will attach the crash report.

Comment 9

16 years ago
Created attachment 110999 [details]
Crash report

Comment 10

16 years ago
Even weirder, the 6/11/02 Trunk does not crash, and I am able to confirm this
bug on it. OS: Win XP.
carine, how is that crash report useful?

Comment 12

16 years ago
Created attachment 111200 [details]
Minimised testcase
OK.  Let's keep things clear here... the crash is a _separate_ bug to be filed,
please.  I still do not see how this is different from bug 78510.  It's the same
problem -- links cannot change link state while a page is being displayed.

Marking duplicate, and please give a clear explanation of the differences if you
decide to reopen.

*** This bug has been marked as a duplicate of 78510 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.